Jetson TX2 Flash & JetPack 3.2 Install

Hi Everyone,

I am new here and am working to get my Jetson TX2 setup. I downloaded JetPack 3.2 onto my linux machine. I wanted to do this on an external USB drive due to space. (17 Gb partition). JetPack installed locally and the downloadable files are on the USB drive.

When I go to flash the Jetson, that portion works. Installing all of the software does not. I get the an issue where it waits 30 seconds to confirm the system is fully up. Then it closes out without going to step 2. At this point the monitor it is attached to turns on and I see ubuntu 16.04. There is no keyboard response. I have tried wireless and a standard usb keyboard.

I then try to install only the software from the installer without the OS Image. It does not complete. It downloads CUDA, then sits there.

I am feeling a bit discourage because I can’t get past this loop. I did try to ssh into it from my host and am able to do so. My laptop is and XPS 9360 running Ubuntu 16.04 connected to WiFi. The Jetson TX2 is connected directly to the router.

Does anyone know what I should do next? I would love to at least be able to login into Ubuntu on the Jetson.

Thank you!
Zack

To post an update. My plan of attack at this point is to uninstall JetPack 3.2 and try JetPack 3.1

Just FYI, you probably need about 40GB of spare space before starting since the file system image itself is about 30GB…plus all kinds of other software on top of that. If the “Linux_for_Tegra/” subdirectory is externally mounted (or some components), then you should also make sure it is formatted as ext4 (some external drives may be preformatted as VFAT or NTFS).

JetPack can actually be run at any time and be set to install only software without flashing, so after a flash, even if software install does not succeed, simply restart JetPack and check only the software part on the Jetson.

The best debug tool is the serial console. This works under almost any circumstance because it basically has no driver requirements…much of the system can fail and this will still work. See:
http://www.jetsonhacks.com/2017/03/24/serial-console-nvidia-jetson-tx2/

Next for testing, you can look at the router and see what the IP address is that was assigned. Then from the host use “ssh ubuntu@”, or “ssh nvidia@”. Login name pass works for either ubuntu/ubuntu or nvidia/nvidia.

Note that if you flashed and ran out of host file system space, then the image flashed will be truncated…the flash process will not warn you about that. Depending on what was truncated there will be a different part of the Jetson’s o/s which is missing. Use “df -H -T /where/ever” to see file system spare space and type for any given directory.

Also beware that JetPack3.2 is a pre-release, not a final production release. There may be issues. R28.1 from JetPack3.1 may be a good test versus JetPack3.2.

Thank you for your response. It is extremely likely that I ran out of space during the initial install and the image was truncated. I am doing the fresh install now. It is actually JetPack 3.2 again. I am using a 128 GB usb drive that is formatted as NTFS. Should I go ahead and abort at this point and reformat?

I am not running out of space this time due to having the larger drive which is promising.

NTFS guarantees failure. The flash won’t show it, but upon reboot the system will not behave correctly. There would be so many things needing repair it isn’t practical…you’d have to flash again after getting rid of NTFS. So…yes…the NTFS must be reformatted.

JetPack 3.1 installed. I believe that the problem was entirely with the usb drive formatting. Thank you for your help!