TX1 inaccessible after OS flash

Hi there!

Host machine is 16.04. I downloaded and installed the latest JetPack (3.2.1) no problem, then flashed the TX1 with the latest OS - no issues there.

However, the TX1’s USB port doesn’t seem to be functional anymore - nothing I plug into it works (a keyboard, a mouse and a usb hub I’ve tested on the host).

Additonally, I cannot access the TX1 via SSH, because, although I have plugged an ethernet cable and connected it to the same router as the host, the device does not appear at all in the network and the port’s LED is off. Same cable works fine on another machine.

I flashed it one more time to make sure that there were no issues, but the issue persists.

The TX1 behaved normally before the flash - both USB and Ethernet.

What do, guys?

TL;DR: Flashed TX1 with new OS, now USB and Ethernet ports do not work.

Was the file system on the PC used for flash a native Linux type? If you used any disk space with VFAT or NTFS a seemingly successful flash would still fail in unexpected ways. Typically “df -H -T /where/ever/you/flashed/from” will show if it is ext4.

If you flashed from a VM you probably need to check the logs. VMs usually fail even if you didn’t notice.

Flash takes a lot of disk space and if you ran out of space during the flash, then a truncated filesystem might break boot. The above “df -H” command also shows available space.

If your host uses 64-bit filesystem options by default, then the bootloader will halt while waiting for a boot device (U-Boot can’t find the boot configuration when 64-bit extensions are used). You can look at the host config file “/etc/mke2fs.conf” and examine the “ext4” configuration block to see its default options. If you see either of these, then you’ll need to force removal of these options for the flash to be valid:


Thank you, that solved it!

My Ubuntu partition did not have enough room for the installation files, so I placed them on the second disk, which was indeed NTFS. Allocated more room for Ubuntu and kept all installation files there - worked like a charm.

Have a good one! <3