TX1 stuck in Force Recovery Mode

My Jetson TX1 is permanently stuck in the Force Recovery mode. I tried to flash the device but this didn’t make any change to the state of the TX1.

Things I tried:

  • Flash with different VMs and Host Machines, both running 14.04 Ubuntu

  • Flash custom images and vanilla firmware from Nvidia

  • Tried with changing the Micro-USB-Cable

  • Tried different carrier boards 2x Auvidea J120 and one DEV-Kit

  • Ping on IPv4 and on IPv6 to determine if network is up, failed

  • Tried different Monitors to see if the linux kernel boots up, nothing to see

  • Tried with different Network Setup

  • Successfully tested the environment with flashing another TX1, wich worked perfectly fine.

What I noticed is, that whenever I restart or unplug the cable the Jetson will be listed as an USB-Device, like it should be when you are putting it into the Force Recovery Mode. Just when I finished flashing the Device and JetPack is trying to determine the IP-Address then the Device ist not listed as an USB-Device checked with: “lsusb”

Does anybody have an idea how to fix this state?

If the Jetson shows up on lsusb at any time when the Jetson has been rebooted without holding the recovery button I’d say there is a hardware failure. Perhaps it is something simple like a small solder bridge or metal dust across the button. If not, you’ll probably need RMA.

The J9 header near the recovery button, when shorted, brings the signal line to ground (one half of that header is ground). When the button is not pushed a powered up Jetson will show approximately 1.8V across that header. Pressing force recovery will bring the voltage to 0. You can place a voltmeter across J9 and see if it has 1.8V when the recovery button is not pressed…if it does, then the issue isn’t a short across the jumper and probably you need RMA. If it is a short, then perhaps you can see some small contaminating conductor to brush away.