Cannot boot Jetson TX1 into Recovery Mode

I am currently trying to boot my Jetson TX1 into recovery mode, but despite following the Jetson User Guide directions (http://developer.download.nvidia.com/embedded/L4T/r23_Release_v1.0/NVIDIA_Jetson_TX1_Developer_Kit_User_Guide.pdf), I keep booting into the GUI login screen.

I powered the device down, unplugged the AC adapter, plugged the MicroUSB cable into a host PC and the USB-B port on the Jetson, then pressed the POWER button while holding down the RECOVERY button for two seconds. I have done this several times now to no avail. I am not sure what I am doing wrong and greatly appreciate any advice.

Another way is to turn on the module, press and hold the REC button and then press the RST button. Hold the REC button for 5 seconds and release. Lsusb on the host machine should return a device named Nvidia.

FYI, two seconds is unnecessary. The gist is that anything which would normally power up the Jetson, if done while recovery button is held down, results in recovery mode.

Suppose power is connected but the green LED lights are not lit…such as after running the Jetson and then doing a “shutdown” command. If you then hold the recovery button down and simply tap the power button, you are in recovery mode (this is instant, no delay required).

I would not advise improper shutdown, but as another example, if your system has the green LED power lights on, and you hold the recovery button down and tap the reset button, the Jetson will go into recovery mode.

Your host can see any recovery mode Jetson TX1 via:

lsusb -d 0955:7721

(Similar for a JTK1, but “lsusb -d 0955:7140”…0955 is manufacturer ID nVidia, 7721 is a TX1, 7140 is a TK1)

I lack more detailed knowledge, but recovery mode implies something at a lower level and prior to U-Boot loading (recovery mode is available even if no boot loader is installed…reaching U-Boot implies you’ve gone past the stage for recovery mode to be available).

You apparently have a serial console available. I am wondering if you have tried reaching recovery mode with no serial console attached?

If you can reach boot to Linux I saw this in another comment for getting recovery mode (I’ve never tried it):

sudo reboot --force forced-recovery

I am curious, if from U-Boot you run the command “boot”, does it do anything interesting in terms of error information? This must be a custom carrier board if there is no USB or SD or ethernet…but U-Boot itself should be able to read or write eMMC memory locations…so what kind of I/O is possible on this board?

FYI, RMA info can be found near the top of this URL:
https://devtalk.nvidia.com/default/topic/793798/embedded-systems/some-jetson-web-links/