Cannot enter TX2 recovery mode

I am trying to get into recovery mode to reinstall ubuntu on my TX2.
However, I have tried to enter recovery mode many times using methods I have seen on the internet, but I cannot enter it and ubuntu boots.
When I run lsusb, it does not show up as “NvidiaCorp”.

The procedure is as follows.
(1) Connect it to the notebook PC (Let’s Note) that contains ubuntu.
(2) Press “power BTN” and make sure the LED lights up, then wait for about 30 seconds.
(3) Press RST for 2 seconds while pressing REC.
(4) Release RST and REC in that order.
(5) Press “lsusb” on your laptop and check if “NVidia Corp” is displayed.

Is there anything that may be wrong with this method? Is there any other way to enter the recovery mode?
Best regards.

Always start with REC pin instead of RST or power BTN.

If the board is not powered on yet, then press REC and hold → press power BTN → release power BTN → release REC

If the board is already powered on, then replace above “power BTN” with the “RST”.

Thanks for the reply.
I tried the method you suggested, but I couldn’t get into the recovery board and ubuntu booted.

What do you mean ubuntu booted?

So the board still boots into OS?

Yes, the ubuntu installed on TX2 boots normally.
However, I need to reinstall ubuntu and I am about to enter recovery mode.
I saw on an internet site that ubuntu will not boot when I enter recovery mode, but I can check it from another computer with ubuntu by using “lsusb”.
So, if I can see ubuntu booting with HDMI connection, I assume it is not in recovery mode.
I have also checked the lsusb command, but I have not been able to see Nvidia Corp.

Could you take a video of how you press those buttons for me to check?

Please make the whole board appeared inside the video if possible.


How about the reset case? And could you connect the HDMI before you press the button?

BTW, you don’t need to press RCM button for so long… you can release it after you release the reset/PWN button.

Sorry for the late reply.
I have tried recovering from boot state.
I have a TX2 that has a problem with no video output when booted with HDMI connected. So, I took videos of two patterns, one with HDMI connected from the beginning and one without.


Looks like what you are doing in “part2.mp4” is already correct. When the board is in recovery mode, no OS is running so it is normal that HDMI won’t show anything.

And just a reminder that… do you know that you need to connect the micro usb port to the device?

Yes. I saw it as something to be connected after entering the recovery mode.

However, when I do “lsusb” from another computer, I can’t see the connection.
Also, if I do the same thing as in part 2 without HDMI connected, and then connect HDMI, ubuntu is running.
Therefore, I believe that TX2 is not in recovery mode.

My TX2 does not output video when booted with HDMI connected, even when it is not in recovery mode.

If even the method in “part2.mp4” is not able to make your board into recovery mode,

Please reboot your jetson TX2, open a terminal on the HDMI monitor, and use command

sudo reboot forced-recovery

This is software method to put the board into recovery mode.

1 Like

Thank you so much for your help.
I was able to enter the recovery mode successfully.
I was also able to check “lsusb”.

Please also check if you have any other TX2 board to validate… it is weird that the buttons not work.

I tried to enter recovery mode with different TX2 boards.
I tried using both the power button and the reset button, but could not get into recovery mode.


Could you dump the uart log during the time you press these buttons?

We were able to see the output from the middle of entering the recovery state.