How can I exit recovery mode?

Hi I’m trying to install jetpack and I faced a problem
the problem is as below

I think my jetson tx2 got into the recovery mode so every time I connected the HDMI, Nothing displayed on the monitor. I got no signal message.
also I think tx2 can’t recognize the ethernet connection.
so How can I exit the recovery mode?

It is quite common for flash to succeed and the system will fully boot, but video does not display. It is a guarantee that if the unit is in recovery mode, then ethernet will not ping or otherwise work. Even if a flash succeeded while video failed, one would possibly find ethernet ping works, but login would not work because you have to complete first boot account setup (you cannot use ssh to connect to an account which does not yet exist).

Recovery mode does not itself make any changes, but does put the Jetson into a mode which turns it into a special USB device understood only by the driver package. Nothing else will appear to function in recovery mode. Default is to not be in recovery mode.

If your monitor purely HDMI without adapters? Is there anything unusual about the monitor? Can you describe your monitor and cables? Which release of JetPack/SDKM did you use?

NOTE: To see what is really going on serial console is by far the best tool See:

Linuxdev, Thank you for the answer!

Yes, my monitor is purely HDMI without adapters and when I connected another PC, the monitor worked well without any problem. so It doesn’t seem like the problem of the monitor. The model is UL TRON2758. I also checked the cable as well. The version of JetPack is 4.2.3 and SDKM 1.2.0

and the sequence that I tried to install is as below.

  1. Installed the ubuntu on the jetson tx2 and the default version was 16.04

  2. Downloaded the Nvidia SDK on the host pc (Ubuntu 18.04). The first time, I checked the wrong board which was TX2 4G so I paused the install and uninstalled all things.

  3. Reset the board setting and reinstalled the Jetpack 4.2.3. When the process reached the manual setting, I set a tx2 as a recovery mode but got errors. so I searched the error and found out that It can be a matter of the ubuntu version.

  4. So installation was failed but the SDK said jetpack is installed (Maybe some components are installed but not fully installed). so I uninstalled Jetpack in the tx2.

  5. To find out the way to upgrade the Ubuntu version in the jetson board, I connected the HDMI to the Jetson. so I realize that is still stuck in the recovery mode.

That’s all that I did. If you think something was wrong or inappropriate, please let me know! Thx!!

For reference, you can find release versions here (“L4T” is what gets installed to the Jetson, “JetPack”/“SDK Manager” is a tool which is used as a front end to flash L4T and to add optional packages). There is a more recent release (you might need to go here, log in, and then go here a second time since redirect does not work):

Also, if your host PC is Ubuntu 16.04, is it possible for you to upgrade to 18.04? Only the older releases actually supported 16.04.

Note that if you want to be sure of what is going on, then serial console is the best way to do this. See:
(this probably won’t matter if all you are getting is a logo, but for almost all other debugging consider serial console the best debug tool)

A quick way is to remove the old packages installed by sdkmanager, let it download a new one and then reinstall again.

According to your description, it sounds like the first installation has been canceled by you, so I wonder if this package really 100% downloaded on your host.

Also, “cannot see anything on HDMI” does not 100% indicate the board is in recovery mode… Maybe it just means your previous installation didn’t work.