Jetson TX2 STUCK in recovery mode after flashing twice even

I flashed my Jetson TX2 and the SDK components failed because it said its in recovery mode. Nothing I do will remove this recovery mode!!!

I then re-flashed my jetson tx2 and again, it is STUCK in recovery mode.

Note that this jetson ahs been working fine even with jetpact 4.2 which i installed via the sdk manager

I see some posts about some network config i dont understand what that means, how does the network affect recovery mode?

please help i dont know what else to do. Can i keep using it with recovery mode on??

Can i manually install Cuda v10? Do i need Cuda if i plan to use only tensorflow-gpu?

Maybe NVIDIA can clarify this, but I’m thinking that once recovery mode is detected that the network is used to determine that the Jetson is rebooted and may simply have a bad error message. Restated, “lsusb” is the definitive way to know the Jetson is in recovery mode, but perhaps SDKM is assuming the Jetson is still in recovery mode until the USB ethernet becomes visible…if the ethernet is not configured correctly, it seems there may be a false assumption of recovery mode (or a bad message which should instead say “USB ethernet not found”).

I am re-flashing it for a third time using this post from askubuntu

power off
hold POWER BTN for 5 seconds
connect usb
micro-B plug recovery port → host
putty serial connection (optional)
Serial line: COM5
Speed: 115200
enter recovery mode
hold REC
press RST
release REC after 2 seconds
verify recovery mode
$ lsusb
Bus 001 Device 003: ID 0955:7c18 NVidia Corp.

Lets see if this works.

Hi LeMoth,

Please make sure there is no environment issue. We can confirm this by manually flashing Jetson:

Manually reset board to clear board status.
Put Jetson device to recovery mode. 
Go to JetPack install directory. For example, ~/nvidia/nvidia_sdk/JetPack_4.2_Linux_P3310/
cd Linux_for_Tegra
Run one of the below command to flash Jetson device:
$ sudo ./ jetson-tx2 mmcblk0p1

You can reference more FAQ from:

Hi Carol,

I will try this in the morning. I see manually reset board how do I do this? Is there a combination of buttons to press? Or a jumper pin?


Hi LeMoth,

See comments from Stephen: [url][/url]

Hi Carol,


I followed stephen’s steps and reset the baord and flash it via command as you said. I did not have problems flashing the board through the SDK the problem was after flashing when it came down to insytalling the SDK components like CUDA etc it says “Jetson device is in recovery mode”

It seems I am repeating myself over this issue.

Maybe you can give me the script to manually install CUDA library and other SDK directly without using the SDK manager?

Please help this is urgent


I think I may have found a solution, so far it is installing the SDK components and not giving me that error message, hope it helps out anyone having the same issue.

After flashing through the OS image and failing at the second step when it is about to install the SDK with the error “Jetson is in recovery mode”

I am using Ubuntu 18.04 LTS and for some awful reason there are 3 wired connections after setup. One is PCI Ethernet, second one is called Ethernet and third one is called NVIDIA Ethernet Conne… (Dont know the full word since Ubuntu decided to redo this section of the UI and screwed up the width I cant get the full name)

Anyways, i turned off PCI Ethernet and Ethernet

And I turned on NVIDIA Ethernet (takes a bit of time to “connect”) and i clicked install on the SDK on the host and currently it is resuming the install process.

However i do not have access to the internet right now so something is up with the way flashing happens.

So far its looking good I will update with any other issues that come up


Hi LeMoth,

It’s good to know you can install SDK components now.
The usb-device mode is enabled and you can get ip address, the SDK components will continue process.
Please let us know if you get any issue.

To make it easier to understand,

What we were talking about (some ethernet interface balabala) is for “installing SDK”. It is using usb interface as a virtual network.

That is, you can ping between host pc and tegra device when usb cable is connected between each other and you don’t need a ethernet router for it.

The problem is some users’ host somehow didn’t enable such interface and cause sdk manager hang.

As for flash OS, it has nothing to do with above interface.

Yes but the problem is that there is a catch 22 somewhere which i cannot figure out. When i booted up the host laptop and when I launched the SDK manager to flash the Jetson it asked me to sign in and that failed because somehow ethernet was disabled. So after troubleshooting why i did not have access to the internet to sign in, i found out that it was disabled so after enabling it, it disables the other ethernet connection profiles which one of them is NVIDIA Ethernet Connect

After logging in, i flashed the TX2 with no issues and then the SDK part failed with that error. So to sum it up, it seems that to use the USB virtual network interface I have to disable internet access on the host else it conflicts, even though on lsusb the JEtson shows up.

Luckily the issue is fixed and everything works now

When you have no Jetson virtual ethernet in use and others are present, what do your “ifconfig” and “route” commands show? When you then add virtual USB, but do not yet disable anything else (presumably not yet working), what do the same “ifconfig” and “route” commands show?

You can use the “code” icon in the upper right (looks like “</>”) and paste your results into that for formatting.