TX2 Dev Kit Isn't Working

I have a TX2 with the original Ubuntu 16.04 OS that shipped with the kit. I had it turned on and working, but got logged out due to inactivity. When I tried to log back in, I used the password ‘nvidia’, but it wouldn’t accept it. I kind of freaked out (I don’t think I had reset it), so I tried a bunch of other passwords and none of them worked. At one point I think I was trying to switch the USB input from a keyboard to mouse (as in physically unplugging the keyboard to plug in a mouse) and it randomly turned off.

I unplugged the AC adapter, replugged it in, and pressed the power button. Only the two red LEDs and the SOC green LED work. The PWR LED does not turn on and the system does not seem to boot. I tried putting it in forced recovery mode, but this didn’t work either.

Did I fry my board? If I did, can I get a replacement?

  • Worried TX2 Newbie

It’s normally much more difficult to fry a Jetson than that. On the other hand, recovery mode should be basically unstoppable. Usually there is a problem with how recovery mode is entered or tested for instead of actual recovery mode failure.

For verifying if recovery mode works, be sure you use the micro-B USB cable which comes with the dev kit (micro-A cables will plug in, but these are for host mode…such a cable is essentially not even connected when in recovery mode). Use only the micro-USB port for testing. Hold down the recovery button, and then either power on with the power button, or else tap the power reset if power is already on. After that let go of the recovery button. There is no requirement to hold for any period of time…the recovery button is similar to the shift key on a keyboard…only a power up or power reset while recovery is held is recovery mode instead of a capital letter.

From your host PC, if you were monitoring “dmesg --follow” while turning on the recovery mode (or plugging in the cable of a recovery mode Jetson) you should see some acknowledgement of seeing a new device. If you run “lsusb -d 0955:” you would see a list of all NVIDIA USB devices. If you run “lsusb -d 0955:7c18”, then you will see a list of all NVIDIA Jetson TX2s.

Are you positive it is in recovery mode with the correct cable, and still does not show up with lsusb?