Jetson Tx2 Doesn't turn on

I just bought a brand new jetson tx2. Connected it to a monitor and power supply and when I press the pwr button the red light flashes and quickly turns off. Am I missing something on how to turn this on for the first time?

Does it need a boot drive? or something else

hold the power button down longer.

Put in recovery mode hold the recovery button down and then press the power on button for a while, release the power button still holding the recovery button for maybe a count of 19, should be in recover mode, where you can now use sdkmanager to download and load everything on your system.

tried that it doesn’t work the red led stays off and it doesn’t show any screen. I think my board was DOA.

Also running ls /dev/ttyUSB* on host has no devices to display

The host will never show a “/dev/ttyUSB*” from the Jetson itself. The only time you will see this on the host is if there is a USB serial UART with the USB end on the host PC (serial console type cable). While in recovery mode a Jetson is a custom USB device, and this means custom driver software…and in this case the “driver package” does not create any device special files, it just directly talks to the Jetson.

Note that the Xavier does produce a “/dev/ttyUSB” from its micro-B USB port, but the Xavier has a built in USB serial UART.

Are you using the default developer kit power supply (assuming it is a developer kit and not a third party carrier board)? Or is this on a third party carrier board? For a TX2 with the developer kit power supply I would not expect the red light to go on and then off. That behavior tends to be associated with a Nano (which does not come with a default power supply).

This is the developer kit jetson tx2 and I am using the included power supply. I am just as confused. Looked up videos online and the cr5 red light stays on when a power supply is connected. but in my case, the red light just goes on and then immediately off when I press the power button. And doesn’t turn on when the power supply is connected.

This is an error. What is connected to the Jetson when the LED goes out?

I initially tried to power on while connecting a monitor and keyboard/mouse. And then later tried with nothing just the power supply plugged in. same result in both cases

Normally a keyboard/mouse/monitor are recommended, and these would not draw enough power to be a problem. Since you are using a development kit with the default power supply I would have to conclude there is a hardware failure in need of RMA. There is an RMA info page here:

I thought as much. Thanks for the assistance. I have a new one ordered in the mail. Hopefully, I won’t have any issues with that one.