New Tx2 not turning on!!!!

I just received a brand new Jetson TX2.
I unboxed it and followed the guide by connecting an hdmi screen and a keyboard and then connected the power supply.
The CR5 LED doesn’t turn on when the power supply is connected and when I click the “Power On” button the TX2 doesn’t turn on. the CR5 LED only blinks once red when the button is pressed.

Is the board deffective or am I doing something wrong?
This is really frustrating to have a board not working after spending so much money on it

Please help!

Hi jadfay,

Please make sure your power supply is connect correct, no cable loose.
Please check below two ways:

  1. Press power on button, check your tx2 can boot up.
  2. Press force-recovery button + power on button, and using ‘lsusb’ command on your host machine to check you can see the device or not.
$ lsusb
Bus 001 Device 085: ID 0955:7c18 NVidia Corp.

Hi thanks for your reply.

  1. I’ve tried pressing the on button many times, but it doesn’t boot up and the red led only blinks once. (I’ve checked the power supply and cables if they’re loose)
  2. I tried that and unfortunately I cannot see the device.
    I can send you a video
    PS I’m using the development kit

Hi Jad.fayad,

I think you can send RMA.

i have the same problem any solution pls it is urgent !!!

Have you tried holding the button down a few seconds? Just a quick press isn’t enough.

Hi arnstein ,

i tried every thing but still doesn’t work i was waiting for the board for 2 weeks for my project and now every thing doesn’t work really i feel bad. They just sell products without even testing them.
thank you anyway

I am facing the same issue. When a power adapter is connected, the CR5 led doesn’t turn on. When I press power button the CR5 led blink and turns off. The board doesn’t boot.

I had an old TX2 development board with which the TX2 processor works fine. We found that the new development board looks different as compared to an older development board.

Later I tried pressing reset + recovery + power button on the new TX2 dev kit, the TX2 boots.
Are the other users facing the same issue.

Is Booting TX2 like this recommended?

TX2 with new dev kit is now booting by long pressing the power button.
Note: In the new Tx2 board, CR5 led is turned off even when the power adapter is connected. It requires long press on power button then the CR5 led turns on. Booting takes a longer time than older TX2 board, so have patience.

hi shinde,

reset+recovery+power doesn’t work for me

thank you

Hi bouzidi.ahhmed,

I think you can send RMA.