Development kit not powering up, only red lights

Hi all,
I have an issue with my Jetson TX2.
In a random fashion, but more frequent in the last period, the device doesn’t want to turn on. When I plug the power, the first red LED turn on (CR5, if I am not mistaken).
When I press the PWR button, another red LED turn on (CR6 LED), but no green light from the two near the PWR and REC button (it should be CR2 and CR1, respectively).
Randomly, after some time, some power cycle, and probably because moon is aligned with Saturn, it decide to complete the power up sequence.
I am using the provided power supply, and as I said, these issues are becoming more frequently and it is always more difficult to get it going.
Do you have any advice to solve my problem? Or could be the board that is dying?

Thank you!

Hi, do you have another dev kit to do cross check to see it is module problem or carrier board problem? Also you can re-flash board to check again. If issue still, then it looks more like a hw issue, you can run RMA process for it.

yes, I have other boards for testing this behaviour. However, how can I switch the module between the carrier? Have I to use some special tool for that strange screw types over the heatsink (I don’t know the name for that kind)?

Moreover, it’s hard to get the board into a flashing mode, since it’s hard to get the board to start (and thus, to use the combination REC+RST).
I don’t understand why a re-flash could help with the fact the board just doesn’t turn on, can you explain a reason why this would help with the issue?

Another question: could the power supply be a cause of a fault? Because if that’s the case, I don’t want to fry the board because of the power source. How can I test for the “goodness” of the power supply?

Thanks again!

Yes, the screw is necessary to switch module. Re-flash is just to make sure that board status during power-on is back to original status. If it can not enter recovery mode, maybe indicates board damaged. To verify power supply, you can measure the output voltage of it to check if it is in the normal range. If can’t find out root cause by all checks, you can run RMA for it.

Hi all ,
i just got the jetson tx2 and while flashing for the first time when i press power ON only a red LED turn on for few seconds and i’m totally lost should i turn the board back ? the first use i’m trying to flash it and it doesn’t even want to power up, any solutions pls ?


1 Like

I, too, and having similar problems with the Jetson TX2 Development Kit. When I first received it, applying 14.5Vdc to the barrel connector only lighted LED CR5 (VDD_IN), as expected, but the unit wouldn’t respond to the standard Force Recovery button turn-on sequence (off / push Force Recovery button / power on / with FR button pushed, momentarily press On button / release On button / release FR button). I mention the Force Recovery sequence in case someone spots a significant error.

Anyhow, after MANY MANY trials of doing this, and also trying other combinations (involving Reset button), one time the unit turned on! Namely, green LEDs CR1 (SOC Enabled) & CR2 (Power), and red LED CR6, all turned on. During this period I was able to flash the OS successfully (JetPack 4.4.1, I think) using SDKManager on my other Linux computer.

Subsequently, the unit turned on normally (i.e., with only a press of the Power On button) for several instances over the next few days, and I began to setup my Ubuntu desktop preferences. HOWEVER, yesterday the DevKit refused to turn on again, with behavior now having only CR5 lit when power is applied, with no other response (other than the PCIE/SATA red LED CR6 briefly flashing every time Power On button is pressed). The only thing I can imagine that happened is that perhaps there’s a problem with ESD protection as I plugged in the nominal 12V external power into the barrel connector (??). I have downloaded the DevKit schematics, but as of now have not figured out a possible culprit for why the unit ceased to turn on, especially since it worked flawlessly for several days.

I really don’t know what to do at this point. Please help! I invested a bit of $ into providing the DevKit with a mini-ITX case and a SATA SSD, and planned on making this my main Linux computer, so it would be great to find out how to fix this!!

Thank you in extreme.

Hi @aclark,

Since this was solved over a year ago, I suggest posting this as a new topic to get better exposure. Someone from the Jetson team will respond in a timely manner.


Tom, thank you kindly! I hope you & yours are staying safe.
Kind regards,

1 Like