Jetson TX2 does not power on

When power supply connected, nothing happens. When i press the power on button with power supply connected, the power LED (CR5) turns on for a second and then goes off. This happens on both long press, instant press and short one second press of the power button. No traces of the device getting powered up. I tried to get into recovery mode but still unsure of what is happening as the device shows no signs of getting power supply.

Would be happy to get some urgent help on this as I have a product demo tomorrow! Thanks!

You probably have hardware failure, but you can do some testing. First of all, is this the stock dev kit carrier board? What all is connected to the unit? Can you try with all USB and ethernet disconnected? If removing everything works, then you might try plugging in the keyboard and mouse one at a time, and then the monitor. If there is anything PCIe, leave it disconnected.

If you can get it to boot without items connected, then you could check the serial console as you plug things in and any item causing failure might produce a message on dmesg as it fails.

Note: If it is a USB issue, then perhaps a powered USB HUB (with the HUB having its own power) will help.

If you’ve moved this module among carrier boards, then you should describe this.

If this is not a stock dev kit power supply, then you should also mention this.

Yes, it is the stock dev kit carrier board. I had only the antennas connected to the unit and then as you said, i have tried with everything disconnected and still i could not power up the device.

I have found a query which has exactly matched with my problem and i have tried the solutions mentioned in that qeustion too and nothing worked.

The above one is the url.

If RMA is the option for me, then I am looking for the Forum admin to respond here because that is what the support guys told me in the chat.

If I can do something else which would hlp me to solve the problem myself, then I would be more than happy to do it.

RMA is probably in order since the inability to reach recovery mode makes it impossible to flash. If interested in this, you can search for “RMA” near the top of this and there is a link into the process:
(“RMA FAQ” and “RMA Procedure”)