Jetson TX2 does not power on (no green led)

My jetson tx2 displays the CR5 LED when powered (by AC adapter), but does not turn on (no visual, no additional red LEDS, no green led, etc.) when power button is pressed.
Thanks for any help on this matter!

Hi, is it new one or used one? Did you check if it can enter recovery mode?

Hi thanks for the reply! It is around 1 year old; I bought it new. I did try recovery mode (please confirm if I did the sequence right) and nothing appeared on the host computer.
Just to confirm- recovery mode is initiated by removing power connection to the board and then reintroducing power with the REC button depressed and then while still holding down the REC button, the RST button is pressed down and released. Two seconds after the RST button is released the REC button is released. Then check if host computer recognizes the jetson usb connection (ex: lsusb). Does that all sound right?
I have tried using the lsusb command on both of my usb ports and my computer has not recognized the jetson.

Some additional details: I have only used the AC power cord to power it. I have used it strictly for running deep learning algorithms on Tensorflow. I am unaware of what happened to trigger the failure in powering on. I didn’t notice anything until I tried turning it on recently. In another similar post someone recommended pressing the power button rapidly a few times in succession; I have tried this to no effect.

I would check some voltage levels perhaps across the Power button, but unfortunately I do not have any measuring equipment to do so.

Is there any thing else I can try to do?

Thanks again!

Your process of recovery is OK. Like other some topics, there might be some components broken, if you have tools such as multimeter, you can probe if any one broken and shorted to GND of board.

If you have no such equipment and experience, you can send the board to do RMA.

Just for reference, which components or terminals would you suggest probing? Also what are potential causes of this? I have read a number of similar issues on the forums, although I have yet to see someone find a definitive source of failure.
Thanks for all your help!

You will find some ESD components near to DC Jack by searching schematic (.pdf type), those might be damaged by ESD.

http://developer.nvidia.com/embedded/dlc/jetson-tx1-tx2-developer-kit-carrier-board-c02-design-files