Unable do boot or flash Jetson TK1

Hi Guys,

Sorry if this topic is duplicated.

But one of my Jetson TK1 suddenly stopped to work. When I boot the Jetson TK1, the only message that I see on serial is:

U-Boot SPL 2014.10-rc2-ge23f13b (Oct 07 2014 - 19:14:48)

And then the Jetson TK1 powers off. It takes 1 or 2 seconds powered on until it powers off.

If I boot the Jetson in recovery mode, it powers on. But when I try to flash, I see the messages in serial:

[0000.000] [TegraBoot] (version UNDEF_BUILD)
[0000.004] Reset reason: power on reset
[0000.008] Processing in recovery mode
[0000.011] Established communication link with host
[0000.042] Downloaded bct successfully 
[0000.046] No Battery Present
[0000.050] Sdram initialization is successful 
[0000.060] Downloaded DTB successfully 
[0000.086] No Battery Present
[0000.157] Downloaded bootloader successfully 
[0000.162] CPU-bootloader entry address: 0x83d88000 
[0000.166] BoardId: 375
[0000.168] Vpr Carveout Base=0x0f4600000 Size=0x00ba00000
[0000.173] Tsec Carveout Base=0x0f2600000 Size=0x002000000
[0000.179] Lp0 Carveout Base=0x0f25ff000 Size=0x000001000
[0000.184] Xusb Carveout Base=0x0f2300000 Size=0x000200000
[0000.189] Platform-DebugCarveout: 0
[0000.216] CPU power rail is up 
[0000.219] Perfor

And then the Jetson powers off again.

Someone has the same issue before? I tried with different 12V power supply with no success. And the same power supply tested worked with other Jetsons TK1. So, this is not the problem.

Maybe some power supply in board is failing to supply the correct power? Or some broken peripheral in board?

I tried to boot the Jetson TK1. Only with serial connected, no USB or other device.

Anyone has seen something similar?

The U-Boot line is just u-boot barely starting up. It should definitely get more log than that.

The second log from flash should show:

[0001.310] CPU power rail is up 
[0001.313] <b>Performing RAM repair</b>
[0001.316] CPU clock init successful

It looks like it’s hanging at RAM initialization. If you can’t even start a flash process, I suspect you have hardware failure and might want to start the RMA process.

Hi linuxdev!

Thank you very much (again) for your help.

I forgot to explain the context when I get the first error: actually, the board was being used before. Then it suddenly powered off and after that I cannot power up it anymore. I think that I used this board for one year, with no failures, until now.

I also suspect of a hardware failure. Maybe overheating caused this?

I’m asking about overheating because I’m concerned about what make this happen. I have other TK1 here and maybe this problem can also happen in other boards if it was caused by an environmental or use condition.

I tend to suspect overheat when specific components in a desktop system fail. I wouldn’t be as likely to blame heat for a TK1 failure simply because even at full use the heat buildup is much lower than from something like a desktop. Still, it is possible if you were continuously running at max CPU and GPU with software taking advantage of that hardware, especially if the fan died before failure.

What I’d consider more likely is a weakness in power delivery, e.g., needing a surge suppressor. Power spikes are so common and so fast that you’d never know it except by a failure. This would be high on my list of suspects. Closely related is static discharge…which can come in through something like an ethernet port if the ethernet and its entire chain of components (such as cable modem or DSL modem) lack surge suppressors.

One thing to know about surge suppressors is that they can’t really be tested, as each surge does damage to them. After enough surges hitting the “crowbar”, they degrade. Older surge suppressors simply drift into worse and worse performance, and may need replacement after a long period of time. In a rough environment they may last a couple of years; in an average environment, they probably last 5 years.