Jetson TK1 not booting

I have two Jetson TK1 boards and I am unable to boot up or go into recovery mode(nothing on windows device manager). And when I press the power button led blinks for half second and fan takes one or 2 turns then nothing. I tried changing adapters. Any help?
Can anyone tell me which pins should I check on board to diagnose if its a hardware or power supply unit fault.

Is it a used board or new one? If a new board, should install recovery usb driver first. If a used one, please check the input current first to see if any device broken and short to GND.

Hi AtifAli,

Have your found the cause and resolved the problem?
Any update?

Thanks

I haven’t found the solution yet. I think the main power IC is damaged as I accidently used the TX1 19V adapter with my Tk1. Because both have same power plug.

I’ve personally never thought to check if the supply requirements are the same or different for a TX1/2 or TK1, so I went to see what the valid supply voltage tolerance is on a TK1…I couldn’t find it. All I could see is that the supply provided on the Jetson dev kit is 12V.

I am curious if anyone knows what the tolerance is for VDD_MUX (the 12V connector) on the TK1 dev board?

Jetson TK1 is characterized to accept an input voltage of 12V +10%. The board may not reliably turn on with < 9.5V. A voltage > 13.2V may damage a SATA HDD using 12V. > 16V, the main board may be damaged.

Is there a way to repair it? I have used a TX1 19V adapter with TK1 accidentally.

The adapter plug for both TK1 and TX1 is same but one is 12V and other is 19V. So, if someone is using multiples kits in the same lap/environment it may cause damage. It happened in my case at least.

If some components broken, then mostly no way to repair.

Nothing looks or seems broken. Only thing that may be damaged is the main power distribution IC. Can I replace that?

Hi AtifAli,

To repair the broken board by finding the burnt chip and replacing it manually will run the risk of voiding the warranty, still suggest to RMA it for a replacement straight away.

RMA information is given near the top of this:
https://devtalk.nvidia.com/default/topic/793798/embedded-systems/some-jetson-web-links/

Thanks

Did anybody ever find a solution to the Jetson TK1 start up power failure problem? I had both the TK1 andTX1 and accidently plug the 19v TX1 power adapter into the tk1, killing the TK1, what no over voltage or over current protection or fast blow fuse, very poor design. I contacted them and as my board is second user so I don’t have the original receipt it tough shit. I have the skills to do the SMD repair If I had the service repair details. Does anybody know what needs to be done, or somewhere in the UK to get it fixed?

Malcolm aka @fixed1t

As described in the Jetson FAQ, the RMA period for the TK1 falls under the 1-year warranty. The Jetson Tk1 development unit was discontinued in April 2018. It would have been impossible to honor an RMA at this time as the warranty would have expired.

I too have a unit that fails to boot and will be starting a new thread to help diagnose the issue, but I have little hope of reviving the unit short of purchasing a second-hand working unit and replacing the storage with the storage from my previous unit.

The thing is I wasn’t interested in activating an RMA under any kind of warranty, what I wanted to know was who is how much it would cost for them to fix my TK1 most companies of much smaller size employ a repair and fix team. I was therefore stunned that Nvidia were not even remotely interested in fixing it at any price. It really was TOUGH your stuck with a dead unit. It seems to me that the 19v overheated the regulator and either dry jointed the joints, or cause a short from the molten solder and in the last case fried the chip. I have some on order and I plan to either do a surface mount repair or take the 12v rail and use a couple of regulators to supply the 5v and 3.3v to the PMU. I’ll know more next week. The annoying thing is its delay my attempts to unlock Jibo an Social Robot based on the K1 whose parent company went bust after allegedly blowing over $70m. being AI he’s server based and they are about to kill his servers. Here he is making light of his upcoming demise in one of my #fixed1t videos https://youtu.be/K1V5blPb4i0 Malcolm aka #fixed1t
p.s. Happy to contribute to a fix the TK1 fix it thread, you never know it may be easier than we think. My first task is a warning video. Regards Malcolm aka #fixed1t

Does the Jibo have a TK1 development board? Or perhaps some custom TK1 board? I’m not sure of the relationship of the TK1 to the Jibo. Either way, I don’t know of any quick fix.

Yes, Jibo has a TK1 I’d read it was the TX1 so bought one, but I was wrong. So I’m trying to obtain another board to test after stupidly thinking Nvidia would be crazy enough to use two vastly different PSUs with the same power plug, especially when they are both likely to be used be a single developer moving up or down the Tegra route.

I’ve ordered some chips from Spain and they should be here next week so I’ll be frying up some old dead Nexus 7 motherboards removing and replacing components, to get my eye in. Malcolm aka #fixed1t

Unless we know if the board used in the Jibo is the dev kit board it isn’t possible to comment on possible replacement parts. If this is the dev board, then schematics are available at the download center, but a lot of products used the TK1 SoC without using the dev kit. The dev kit was not originally designed to be a popular end product (this was originally just a reference design for people building their own boards). Is the Jibo failing, or is a replacement board failing?

If this is a dev kit board, then the schematic does show a number of points of possible failure. I don’t know if those are all exposed where a simple meter could read the voltage, but if it is exposed, then a specific failed component could be tested for and perhaps replaced.

Hi, my TK1 is still not starting up so I’ve been checking out the Power Chain

I tested the input and output of the U5C1 regulator and to my surprise all of the output voltages are in spec as can be seen from the picture so it looks like the TPS51220 is not damaged, which is very od as its the first component in the chain when I applied 19v from the TX1 PSU to the TK1. On powering on the fan starts and stops and nothing else happens but the output voltages from u5C1 are still there. Can you suggest where i next test for the fault. Here is the test diagram

for some bonkers reason it didn’t go and get the image

Btw, the fan operation is normal. Until heat is generated there is no reason for it to run.

You are correct about a missing image causing problems :P Did you get it to work again with a flash?