Jetson TK1 is not powering, new product

I have a jetson tk1, I have waited for the device 1 month to reach from US to Europe, Romania. I can not power up the device. When I plugin in the power cord, the cooler makes a rotation than stops ?? The power led blinks once than nothing. What should I do ? Please help

Assuming power is working correctly, this would be a hardware failure. If you have another 12 volt adapter to try, or else a voltmeter to test the adapter while it is actually connected to the Jetson, you could tell if the fault is in the adapter or the Jetson. Either way you’ll end up doing RMA for either the whole Jetson or the adapter. The RMA people could possibly give more specific testing information.

Here’s the RMA info:

Go to www.nvidia.com/nvcc

  1. Select “Live Chat” from the options near the top of the page.
  2. Enter your personal information.
  3. Select the appropriate product from the drop-down list (“Tegra” in this case).
  4. Submit the request.
  5. If the Service agent is unable to resolve the technical issue, an RMA (Return Material Authorization) will be initiated.

I have measured the power adapter, it is exactly as it should .
I have tried with a different power adapter with the same specs.
I have connected an adjustable professional power adapter, with fine control and tried at 12 V, 12.2, 11.9, 12.4 and the same.

The device starts to power, the cooler makes 2 turns, the power blinks and that’s it, I guess it stays in some kind of stand by. I have tried to measure the FRONT PANEL PINS, after I power the device, the front panel pin that should output 2.5 V works, all the other are not giving anything. I tried to measure the pins while powering on, all of them are starting to give some power in the first half of second.

I was thinking, maybe I have a version that does not have an operating system ?
I have to connect it first with the serial port in order to start ? or something ?

I was thinking about flashing , but I don’t know what’s the normal behavior, When you guys try to flash the device, it stays on ? or it is an a standby mode until you flash ?

Thanks

This is definitely not “normal” behavior.

The last thing to try is to just press either the power button (next to the SATA MOLEX power connector), or the reset button (middle of the three small buttons) to be sure. There are times when a charged capacitor stops automatic booting after power is turned off and back on, but in those cases the fan and power LED do not blink the way you describe (even in those cases once power starts to run the fan and LED remain on…true even in the case of a failed boot).

A very minor possibility is that one of the devices connected via USB or video ports has an issue. Test if LED and fan remain on or still just blink with all devices removed other than the power connector (I have had a USB printer failure cause this problem on custom x86 hardware).

As disappointing as it may be, all indications are that the device has a fatal hardware failure. If power and reset buttons do not work, I would start the RMA procedure and see if the live help desk people have further tests to try.

That’s it, they said that I should talk with the company i have purchased from…
Another 1 month to send the product and another to receive… this is…neverending

Would you please check if the board could boot into recovery mode ?
Keep force recovery(SW5E2) pressed during power on, check the USB device available with USB cable connected to USB0 port(micro AB)

is there hot on board? this may be power or chip damage if some components is very hot.

nothing hot on board, checked that yesterday.

The force recovery, with USB cable should detect something also on Windows ? or do I need Linux just for that ?

Recovery mode is independent of what is attached to the cable. However, recovery software was meant to run from linux. This in no way stops windows from seeing the USB device which Jetson becomes in recovery mode, it simply means you cannot flash from windows.

If windows or linux is connected via the micro-B USB cable provided with Jetson in normal operation, the linux or windows host will not see Jetson…Jetson will be invisible. In recovery mode, linux and windows will see the device, but require software to make the device useful. Flash software is what makes it useful. Windows won’t know what to do with the recovery mode device, but it will see a new USB device and probably ask what you want to do with it, e.g., find a driver.

Technically, you could test for heat in recovery mode with no cables attached at all. On the other hand, seeing a USB device appear (or not appear) verifies if Jetson is truly in recovery mode (or failing recovery mode). Seeing a USB device as Jetson powers on in recovery mode would verify a subset of the hardware works; verifying no USB device appears would verify low level unrecoverable hardware failure.

Thanks linuxdev’s explanation,it is detailed and very useful.
If you see a USB device in windows device management or linux, it would say TK1 and PMIC works.
Then you could try to flash the board and check the UART log for what happen.

i put the usbdriver and nvtest tool(for windows) for emmc and ddr read and write test in another topic #3:

https://devtalk.nvidia.com/default/topic/841202/a-tegra-k1-problem-on-sdrams-found-when-flashing-the-emcc-flash-probably-something-on-hardware/?offset=3#4562687

I found the problem, there is a problem on the board, one of the power sources has an electronic problem . Meanwhile I bought 2 TK1 and I will try to fix this one if I will find the small circuit to buy.

Would you give a detail of the problem ?

I was trying to get the SPI working. While I was connecting this pins to SPI, suddenly Jetson stopped working. It is not powering up, neither is the led on, I tried powering from different adaptors it still does not work

It is subject to electrostatic discharge, even if the unit isn’t powered up. Wiring a unit which has power connected would be a bigger problem. The RMA procedure is here:
https://devtalk.nvidia.com/default/topic/793798/embedded-systems/some-jetson-web-links/

i got the same issue and it gets very hot

What should i do ?

It definitely shouldn’t get hot. Even maxed out any of the Jetsons are a lot cooler than an ordinary desktop. Assuming nothing plugged into it is shorted, e.g., something on USB, then it is time to RMA.

Here’s a repost on RMA:
Go to http://www.nvidia.com/nvcc

  1. Select “Live Chat” from the options near the top of the page.
  2. Enter your personal information.
  3. Select the appropriate product from the drop-down list (“Tegra” in this case).
  4. Submit the request.
  5. If the Service agent is unable to resolve the technical issue, an RMA (Return Material Authorization) will be initiated.