Problem with onboard camera with new driver even after reflashing with new cboot.bin L4T 28.1

I have this code not changing the auto-exposure time to manual with OV5693 camera with this command:

gst-launch-1.0 nvcamerasrc fpsRange="120.0 120.0" auto-exposure=1 exposure-time=0.0033 ! 'video/x-raw(memory:NVMM), width=(int)320, height=(int)240, format=(string)I420, framerate=(fraction)120/1' ! nvtee ! nvvidconv flip-method=2 ! 'video/x-raw(memory:NVMM), format=(string)I420' ! nvoverlaysink -e

but with older L4T release it worked ok.

hello pavlobuidenkov,

could please you share more details,
are you able to get camera works with default sensor mode
please gather kernel messages when you got the failure.

It is working in both modes. The problem is that auto exposure time doesn’t become manual. and the


is changing some different parameter of colour.

It needs for me some time to reproduce this problem so I’m doing the development now on the later version of L4T 24.2.1. Do you have the board with L4T 28.1 functional on your side and try to run the command?

Hi pavlobuidenkov,

Could you try set exposure time by nvgstcapture-1.0?

  1. Launch with nvgstcaputre
  2. Change the exposure setting command: ext:0.0033
  3. Press J to capture image
  4. Check your output image

Please update your result. Thanks!