Problem with opengl example

Hello,

I have installed the version 2.2 of Cuda (because my graphic card doesn’t support the new version) and I tried to run the example in the SDK. For most of them, it works, for example: DirectX 9, (not directX 10), or example which don’t use OpenGL.
My problem is when I try to use example which use OpenGL: it fail! The error is:
cudaSafeCall() Runtime API error in file <.\SimpleGL.cpp>, line 344: initialization error

This line is:
cutilSafeCall(cudaGLRegisterBufferObject(*vbo));

So what’s wrong ? If I check my OpenGL extension, VBO are well-supported. There is a problem with OpenGL example on my laptop … ? I have an Asus N61J, my graphic card is an GT 325M. I hope you could help me …

Well, I looked for information on the forum, and nobody have my problem … rah! :D

It’s very strange because if I try DXD10 sample, it doesn’t work, only DXD9. Do you think it could be due to my graphic card which uses optimus technology ?
How can I fix my problem ?
I would like play with cuda. :P

What makes you think your GPU doesn’t support the latest version? CUDA 3.0 supports all cards 8800 GTX through GTX 480. Nobody on the forums is likely to help debug an issue with CUDA 2.2.

Hello MisterAnderson42, thanks for your reply. :)

In fact, I have an optimus graphic card (Intel + GT 325M), and the new driver (191.xx) doesn’t work on my laptop. Thus, I’m in 189.xx version, which support only Cuda 2.2 or lower.

So nobody could help me due to my version of cuda ? :/

What?, optimus technology (which is very new) needs such an old driver that you can only use Cuda 2.2? That seems very unlikely or not?

Yes I know, Optimus is new, but on my laptop (Asus N61J) there is only one driver which support Optimus: 189.xx version. However, for Cuda 2.3, I must have at least 190.xx driver.

I have some news: when I try to compile my Cuda application (Ex: SimpleGL) with EmuRelease, it works . . . So it’s very strange . . . It still doesn’t work with SimpleGL in Release mode. Is it my graphic card which is faulty or my laptop or my driver ?