[SOLVED] NVIDIA CUDA [version 8.0] cudaErrorDevicesUnavailable using simpleGl sample

I had failed visual studio integration during the installation of CUDA 8.0.
To solve this problem I followed this topic : https://devtalk.nvidia.com/default/topic/1033111/cuda-setup-and-installation/cuda-9-1-cannot-install-due-to-failed-visual-studio-integration/1.
For instance : uninstall windows 10 -> install windows 10 -> install visual studio community 2013 -> install cuda 8.0 -> install newest nvidia driver.

I launched the deviceQuery sample which works.
Then I tried to launch a graphics sample the one I chose was simpleGL.
It brings me this :

simpleGL (VBO) starting...

CUDA error at C:/ProgramData/NVIDIA Corporation/CUDA Samples/v8.0/2_Graphics/simpleGL/simpleGL.cu:491 code=46
(cudaErrorDevicesUnavailable) "cudaGraphicsGLRegisterBuffer(vbo_res, *vbo, vbo_res_flags)"
Appuyez sur une touche pour continuer...

Now, it seems there is a failure in the installation of CUDA which brings graphics error.
I am running on a windows 10 with an NVIDIA GeForce GTX 1070 version 397.64.

Any idea to solve this problem ?

are you on a laptop? If so:

https://devtalk.nvidia.com/default/topic/1032939/is-there-any-way-to-display-such-cuda8-0-samples-as-mandelbrot-/

I am not on a laptop. I bought a DELL computer. As I got this problem, I uninstall windows and install a fresh one without the DELL stuff.

EDIT : Thanks to your link I found that I had two GPU, one NVIDIA and one INTELL.
And… one of my screen was on the intel GPU. Just moving the wire onto the NVIDIA GPU solved the problem.