Problem with Sobel Filter display problem with freeglut

Hi,

I am connecting CUDA machine as
ssh -X username@add

I am trying to run sample program SobleFilter from the NVIDIA_CUDA_SDK/projects/SobelFilter directory as

…/…/bin/linux/release/SobelFilter -file=data/lena.pgm

i got following error
Using device 0: GT200
freeglut (…/…/bin/linux/release/SobelFilter): Unable to create direct context rendering for window ‘Cuda Edge Detection’
This may hurt performance.
Segmentation fault

when tried on the machine itself as
…/…/bin/linux/release/SobelFilter -file=data/lena.pgm
got following error
Using device 0: GT200
freeglut (…/…/bin/linux/release/SobelFilter): OpenGL GLX extension not supported by display ‘:0.0’

this is how xorg.conf looks like
/************************************************

nvidia-xconfig: X configuration file generated by nvidia-xconfig

nvidia-xconfig: version 1.0 (buildmeister@builder58) Thu Jun 5 00:08:24 PDT 2008

Xorg configuration created by pyxf86config

Section “ServerLayout”
Identifier “Default Layout”
Screen 0 “Screen0” 0 0
Screen 1 “Screen1” 0 0
InputDevice “Mouse0” “CorePointer”
InputDevice “Keyboard0” “CoreKeyboard”
EndSection

Section “InputDevice”

# generated from default
Identifier     "Mouse0"
Driver         "mouse"
Option         "Protocol" "auto"
Option         "Device" "/dev/input/mice"
Option         "Emulate3Buttons" "no"
Option         "ZAxisMapping" "4 5"

EndSection

Section “InputDevice”
Identifier “Keyboard0”
Driver “kbd”
Option “XkbModel” “pc105”
Option “XkbLayout” “us”
EndSection

Section “Monitor”
Identifier “Monitor0”
VendorName “Unknown”
ModelName “Unknown”
HorizSync 30.0 - 110.0
VertRefresh 50.0 - 150.0
Option “DPMS”
EndSection

Section “Device”
Identifier “Videocard0”
Driver “nv”
VendorName “NVIDIA Corporation”
BoardName “Quadro NVS 280”
BusID “PCI:1:8:0”
EndSection

Section “Device”
Identifier “Videocard1”
Driver “nv”
VendorName “NVIDIA Corporation”
BoardName “Tesla GT200”
BusID “PCI:3:0:0”
Option “UseDisplayDevice” “none”
EndSection

Section “Screen”
Identifier “Screen0”
Device “Videocard0”
Monitor “Monitor0”
DefaultDepth 24
SubSection “Display”
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section “Screen”
Identifier “Screen1”
Device “Videocard1”
Monitor “Monitor0”
DefaultDepth 24
SubSection “Display”
Viewport 0 0
Depth 24
Virtual 800 600
EndSubSection
EndSection
************************************************/

would appreciate any support

thanks
shrikant

OpenGL interop with CUDA over X forwarding does not work, nor will it in the foreseeable future.

thanks for the reply

but i am facing same problem on the CUDA console, as i have mentioned in the first mail.

when tried on the machine itself as
…/…/bin/linux/release/SobelFilter -file=data/lena.pgm
got following error
Using device 0: GT200
freeglut (…/…/bin/linux/release/SobelFilter): OpenGL GLX extension not supported by display ‘:0.0’

This is probably because OpenGL runs on the card of the host from which you connect via ssh, not the GT200 of your server.

The actual problem here is that your X server isn’t using the nvidia X driver.

now i have installed NVIDIA-Linux-x86_64-173 driver insted of 175 and now able to see some out put of sobleFilter.

but output is not clear. output is attached below.

thanks
shrikant
Screenshot__Cuda_Edge_Detection__Original_Filter___16949.2_fps.png

From your output below:
Using device 0: Device Emulation (CPU)

You’re still not using the NVIDIA driver.

Please run nvidia-xconfig as root, restart X, and try again. Generate and attach an nvidia-bug-report…log if you need further assistance.

Hi,

I am using NVIDIA driver and i got device info as “Using device 0: GT200”. this is explain in my first post.

here i am attaching log file for your reference.

thanks
shrikant
nvidia_bug_report.log.tar (180 KB)

No, netlama is right, you are not using the driver, see above in your last post