Procedure for changing nvcc compiler options in VS2010

Display card of CUDA GPU is: Tesla K20c
on Windows7, CUDA 4.0 is correctly installed, and I use Visual Studio 2010.

I want to remove “compute_10,code=sm_10” from Code Generation option in Visual studio 2010. So, I set Code Generation option to only “compute_20,code=sm_20” .
But this setting is not reflected in nvcc compiler option and following message appear:


error 10 error MSB3721: command ““C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v4.0\bin\nvcc.exe” -gencode=arch=compute_10,code=“sm_10,compute_10” -gencode=arch=compute_20,code=“sm_20,compute_20” --use-local-env --cl-version 2010 -ccbin “C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\bin” -I”./" -I"…/…/common/inc" -I"…/…/…/shared/inc" -I"C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v4.0\include" -G0 --keep-dir “Debug” -maxrregcount=0 --ptxas-options=-v --machine 32 --compile -D_NEXUS_DEBUG -g -deviceemu -D_DEVICEEMU -Xcompiler “/EHsc /nologo /Od /Zi /MTd " -o “Win32/Debug/template.cu.obj” “C:\ssytnt\CUDA\12_atomic\template.cu”” exit with code 2 C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\BuildCustomizations\CUDA

why is "-gencode=arch=compute_10,code=“sm_10,compute_10” remained?
Please tell me which procedure is wrong.