PTX ISA version error

I am trying to update my OptiX and CUDA Toolkit installations to the most recent versions (4.0 and 7.5, respectively), and I’m hitting the following error:

OptiX Error: Parse error (Details: Function “_rtProgramCreateFromPTXFile” caught exception: (string): error: Cannot parse input PTX string my_compiled_ptx_filename.ptx, line 9; : fatal error : Unsupported .version 4.3; current version is ‘4.0’ [4849859], [4849859])

ISA version 4.3 seems to be correct for a PTX compiled with CUDA Toolkit 7.5. Any idea why the current version that OptiX would be looking for is 4.0? I’ve checked that I’m including and linking against OptiX 4.0, and not the older version still hanging out somewhere on my HDD. The release notes for OptiX claim that it was built with Toolkit 7.5, so I would think that I would be able to use it.

I’m running a GTX 1080 (founder’s edition) with driver version 368.81. The release notes for Optix 4.0 say that it requires a minimum driver version of 368.86, but such a version doesn’t seem to exist, even as a beta.

Alternatively, is there a way to force NVCC to spit out a PTX file compiled for ISA version 4.0, other than uninstalling version 7.5 and downloading and installing an older version of the CUDA Toolkit? I looked for a command-line option in the NVCC docs and came up blank so far, but I could have missed something.

After sending this message, I figured out what my problem was. It was user (me) error. I had checked that I was linking against the proper Optix 4.0 libraries at compile-time, but I had forgotten to copy the Optix 4.0 DLLs from the bin64 folder over to the proper location to be visible to our published tools.