PVF 14.10 with VS shell installation problem(s)

Hi,

I have downloaded the trial version of PGI Visual Fortran 14.10 with Visual Studio shell, and installed it after first installing the MS SDK 8.1. During the installation of VS, I got two error messages:

"One of the final setup steps failed during the configuration of MVS: (Code 2) This problem can be resolved after installation completes by running the following command in a PGI Command Prompt window: CMD> “devenv.exe /setup”

and a similar one, where the command “devenv.exe /installvstemplates” should be run.

First, I am not able to start a PGI Command Prompt window. When clicking on any of the “PGI Visual Fortran” → “Command shells” on the start menu, a window flashes, but nothing more happens.

I then try to run the commands from the Windows CMD command line, but both returns with the useless error message “The operation could not be completed”.

Visual Studio still starts, and compiles my little “hello world” program. But when I try to run the debugger (F5), it just locks up, and I have to kill it from the task manager.

I don’t know if these two issues are related, or how to solve them, so any input is appreciated.

I run Windows 7, and I’m the administrator on this computer.

Regards,
Bjørn

Bjørn,

I would make sure the checksum of the download matches the
expected value. If you do not have a checksum, you can find one for
windows at
http://www.nullriver.com/downloads/Install-winMd5Sum.exe

pvf64-shell-1410.exe should have an md5 checksum of
‘509330bb7d89eaf18c799395bff2e1ea’.

So remove the PVF 14.10 installation, make sure the download
has the correct checksum, and install again.

I believe you can open a windows command shell window, cd to the
directory with the download, and run the ‘devenv.exe /setup’
command.

dave

Thanks for the suggestions, Dave. I checked the checksum of the download with winMd5Sum, and it is the same as the one you posted.

As I mentioned in my first post, I have tried to run the devenv.exe commands from the windows command shell, but they both returned with “The operation could not be completed”.

But I will try again, by removing all parts of the installation and start from the beginning.

Bjørn

I removed Windows SDK, Visual Studio and PVF, and ran the installation again. I didn’t download the installation file again, since the checksum was correct.

During the installation I got the following error messages:
“RegDBGetKeyValueEx(%s,%s): Value not found
Software\Wow6432Node\Microsoft\VisualStudio\10.0\Setup\Vs”

followed by

"One of the final setup steps failed during the configuration of MVS: (Code 2) This problem can be resolved after installation completes by running the following command in a PGI Command Prompt window: CMD> “devenv.exe /setup”

and

as above, but “devenv.exe /installvstemplates”

Then
PGI Visual Fortran 14.10: CreateFile failed in CreateBatFile

CreateFile(\PGIVisualFortran, pvf_64.bat) failed in CreateBatFile

Does this give any leads?

Otherwise, the behavior is as described in my first post.

Some programs I have installed have not behaved properly when installed in the program files directory, and I have had to install them in another directory to make them work. I could try that with PVF too.

Regards,
Bjørn

Installing in a different directory didn’t help.

But I tried to install the trial version on my laptop, and had no problems. So it may be a problem with my user account on the other computer.

-Bjørn

Just to make sure of some things.

  1. You downloaded the file pvf64-shell-1410.exe and had a checksum of 509330bb7d89eaf18c799395bff2e1ea

  2. you downloaded the 8.1 SDK file pointed to by
    Windows SDK and emulator archive | Microsoft Developer
    and verified it installed. You may have downloaded and installed a newer one, and I wanted to eliminate that as a reason.
    If you downloaded a different 8.1 SDK, try removing it and putting in the
    other one.

If problems persist, try downloading the workstation product,
pgiws64-1410.exe and see if the command line compilers install.
If they do, the PGI command window should work to install
PVF via the
devenv.exe /setup

keep a log of the manual install, and if it fails again, send it to
trs@pgroup.com, so our Windows engineers can look at it.



dave

I also have the same problem and I still can not fix it…I installed VS2013 however PGI installer want to use VS2008. I can not change the destination directory. and install can not find VS2013 because it do not use Visual Studio 13.0 etc… This may be a bug…

yours

Y. Morita Ph.D

If you have any Visual Studio ‘express edition’ products installed,
you must remove them. They will break and confuse the installation.

Look at Control Panel->Program and Features
and see what Visual Studio and PGI products are currently installed.

I am sorry if this is already known in your mail- what version of Windows are you running?

Oh my god!
I must use Visual Studio 2008 for other programing
I think many other people also have to use Visual C++ etc for many programing… It’s so hard to remove it.
I think, as I wrote, old Vs2008 in my PC may affected to PGI installer in my case, however I must use it for many my old codes.

Thank you your advice.!

I have removed all visual studio express version now.
Without Express version, I can install Visual Fortran correctly.
However I can not make a correct path for compiler…

OutPut
The compiler(pgfortran.exe) cannot be found.

Please tell me how to make a correct path.

Y morita Ph.D

Dr. Morita,

I am not sure what you are saying.

If you run PVF (ie Visual Studio) , are you unable to compile programs?

If you are trying to run pgfortran from a command window
Start->Programs->PGI Visual Studio->Command Shell(64)
should give you a window with the PGI environment is set up.

dave