Python script won't auto run at start up

I am having trouble trying to get a Python script to execute at start up. Currently all the script does is opens a file and writes to it.

I have tried using Startup Applications and cron with no luck.

I have also tried the advice in this thread: Jetson nano auto run python code when power up - #3 by xuanthinh010110






None of these methods have worked and I am at a lost as to why. I have confirmed that the python script works when run using python. I have also confirmed that the bash script works when running it independently. However, the script isn’t executed at reboot.

When I run:

systemctl list-units --type=service

I can see the service there, but it is in “activating” status.

Has anyone been able to autorun a script on boot on the Jetson Nano?

Was able to resolve this issue by using Startup Applications and enabling autologin as detailed in this post: Jetson Nano auto log in account when poweron without need to press enter - #13 by carolyuu

Nice! Glad to know issue fixed. Thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.