PyTorch and torchvision versions are incompatible

Hi

I am using the below JETPACK with a JETSON AGX Xavier.
JetPack 5.0.2 (L4T R35.1.0)

I tried the NVIDIA L4T PyTorch from the NGC catalog, but the 32GB Xavier didn’t have enough disk space! !
Therefore the container cannot be used.

I installed the whl of PyTorch v1.11.0 by following the forum content below.
https://forums.developer.nvidia.com/t/pytorch-for-jetson/72048

pytorch can use cuda. So far so good.
a

I installed pytorch v1.11.0, so torchvision installed 0.12.0, see below.
https://github.com/pytorch/vision#installation

I installed torchvision using pip.

However!
When using YOLOv5 it outputs the error below.

RuntimeError: Couldn't load custom C++ ops. This can happen if your PyTorch and torchvision versions are incompatible, or if you had errors while compiling torchvision from source. For further information on the compatible versions, check https://github.com/pytorch/vision#installation for the compatibility matrix. Please check your PyTorch version with torch.__version__ and your torchvision version with torchvision.__version__ and verify if they are compatible, and if not please reinstall torchvision so that it matches your PyTorch install.

It’s very troubled.
help me.

Hi,

Please try our PyTorch1.13.0 nv22.09 with TorchVision 0.15.0.
Details can be found in the below topic:

Thanks.

@AastaLLL

Thanks for your comment.
Where can I get PyTorch1.13.0 nv22.09 and TorchVision 0.15.0?
I want PyTorch and TorchVision in whl format.

Thank you

I have resolved this issue!!

I’ll record the command I typed for reference.
I use PyTorch1.11.0 so torchvision specified 0.12.0. This is the rule.

git clone --recursive --branch v0.12.0 https://github.com/pytorch/vision --depth 1
cd vision
python3 setup.py install --user
pip3 uninstall torch torchvision
sudo pip3 install torch-1.11.0-cp38-cp38-linux_aarch64.whl
pip3 list

b

I got YOLOv5 working. It’s working as expected.

Thanks for the feedback.
Good to know it works now.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.