Question about edk2 UEFI build

Hi when I tried to build UEFI image, I got error as below picture, could you please have a look about this issue?
I cannot find any information about this.

and based on above picture, you can find the mono python etc already installed ,

I don’t know how to install edk2-acpica-iasl and mu_nasm or setup folder for them

It looks like still some build environment issues.

Please refer the following instruction to build w/o docker on a standalone Ubuntu host PC
Build without docker · NVIDIA/edk2-nvidia Wiki · GitHub

Please also refer this to install Stuart
Installing and Setting up Stuart - Installing on Linux

And the following link for mono
Download - Stable | Mono

thanks Kevin, I have installed above tools

I agree there maybe some issue related to edk2 and environment setting, since when I modified the configuration in edk2 folder, I got some different build result.

will try both with docker on X86 platform and without docker on Xavier, see which one can work

is there any more information/guideline about
it’s in edk2-nvidia/Platform/NVIDIA/Jetson folder.

that I found the error happened when operating at “stuart_setup …/” and “stuart_update …/” in

sorry, there’s no docs for
You might could refer to build scripts located in edk2-nvidia/Silicon/NVIDIA/scripts/

Have you finished download and install Mono in this way?

Mono already installed , you can find on the top of first picture:

nvidia: command found: mono

Yes, I saw that, just make sure mono installed properly.
There are still some dependencies, using that way to install it completely.

Could you try the following command to check if it could help?

$ git submodule update --init --recursive

tried git submodule update --init --recursive, and boringssl files downloaded,

but still get same error: could not find appropriate folder for mu_nasm and edk2-acpica-iasl

I guess I just find the reason, that both edk2 with docker and without docker, the guideline is only for the x86-64 platform, that’s the reason no approprieta folder for mu_nasm and edk2-acpica-iasi

I have gone through the build process on edk2 with docker on X86_64 platform, so this issue can be closed,

And the command git submodule update --init --recursive is required too in this build process


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.