Sorry to bother you
I need to regenerate the UEFI file to fit the R35.4.1 version, I first downloaded it from the official website Release r35.4.1: chore: Update release version to 202210.3 · NVIDIA/edk2-nvidia · GitHub then I ran sudo ./build.sh and display ./build.sh: line in edk2-nvidia-r35.4.1/Platform/NVIDIA/Jetson 25: edk2-nvidia/Silicon/NVIDIA/scripts/prepare_stuart.sh: I didn’t have that file or directory, and then I followed the Home · NVIDIA/edk2-nvidia Wiki · GitHub error message is displayed:The git command: git clone --no-checkout --progress -v GitHub - NVIDIA/edk2-nvidia: NVIDIA EDK2 platform support /home/hz/alex/edk2-nvidia-r35.4.1/edk2-nvidia failed to complete during the build of the workstation successfully with the following errors., what should I do if I am faced with this situation, and which branches should I download if I want to manually download the compressed package to the workstation, thank you for your guidance

Hi liuyuze,

Please refer to the following instruction to setup your build environment.
Build without docker · NVIDIA/edk2-nvidia Wiki (github.com)
and use the following command to clone the source for r35.4.1.

$ edkrepo clone nvidia-uefi-r35.4.1 NVIDIA-Platforms r35.4.1

Regarding the cloning issue has been solved, I think it is a problem with my network

Hello after successful cloning I thought I could successfully build UEFI, but when I run edk2-nvidia/Platform/NVIDIA/Jetson/build.sh, his error is like this, can you have the relevant experience to solve this problem. Is it because my environment is misconfigured or if there is a problem with the clone

hz-nvidia-uefi-r35.4.1 [r35.4.1]$ edk2-nvidia/Platform/NVIDIA/Jetson/build.sh
nvidia: building from workspace rooted at: /home/hz/alex/edkrepo/nvidia-uefi-r35.4.1
nvidia: found command: python3.
nvidia: found command: virtualenv.
nvidia: found command: mono.
nvidia: found command: aarch64-linux-gnu-gcc.
nvidia: Activating Python virtual environment.
nvidia: Building from tarball
nvidia: Updating build environment (edk2-nvidia/Platform/NVIDIA/Jetson/PlatformBuild.py).
Unable to use edk2-nvidia/Platform/NVIDIA/Jetson/PlatformBuild.py as a UpdateSettingsManager
Did you mean to use a different kind of invocable?
Traceback (most recent call last):
File “/home/hz/.local/lib/python3.8/site-packages/edk2toolext/edk2_invocable.py”, line 196, in ParseCommandLineOptions
self.PlatformModule = import_module_by_file_name(os.path.abspath(settingsArg.platform_module))
File “/home/hz/.local/lib/python3.8/site-packages/edk2toollib/utility_functions.py”, line 406, in import_module_by_file_name
File “”, line 848, in exec_module
File “”, line 219, in _call_with_frames_removed
File “/home/hz/alex/edkrepo/nvidia-uefi-r35.4.1/edk2-nvidia/Platform/NVIDIA/Jetson/PlatformBuild.py”, line 10, in
from edk2nv.stuart import NVIDIASettingsManager, NVIDIAPlatformBuilder
File “/home/hz/alex/edkrepo/nvidia-uefi-r35.4.1/edk2-nvidia/Silicon/NVIDIA/edk2nv/stuart/init.py”, line 10, in
from .builder import * # noqa
File “/home/hz/alex/edkrepo/nvidia-uefi-r35.4.1/edk2-nvidia/Silicon/NVIDIA/edk2nv/stuart/builder.py”, line 10, in
from edk2toolext.environment.uefi_build import UefiBuilder
File “/home/hz/.local/lib/python3.8/site-packages/edk2toolext/environment/uefi_build.py”, line 19, in
from edk2toollib.uefi.edk2.parsers.targettxt_parser import TargetTxtParser
File “/home/hz/.local/lib/python3.8/site-packages/edk2toollib/uefi/edk2/parsers/targettxt_parser.py”, line 9, in
from edk2toollib.uefi.edk2.parsers.base_parser import HashFileParser
File “/home/hz/.local/lib/python3.8/site-packages/edk2toollib/uefi/edk2/parsers/base_parser.py”, line 11, in
from edk2toollib.uefi.edk2 import path_utilities
File “/home/hz/.local/lib/python3.8/site-packages/edk2toollib/uefi/edk2/path_utilities.py”, line 17, in
class Edk2Path(object):
File “/home/hz/.local/lib/python3.8/site-packages/edk2toollib/uefi/edk2/path_utilities.py”, line 277, in Edk2Path
def GetContainingModules(self, input_path: str) → list[str]:
TypeError: ‘type’ object is not subscriptable

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/home/hz/.local/bin/stuart_update”, line 8, in
File “/home/hz/.local/lib/python3.8/site-packages/edk2toolext/invocables/edk2_update.py”, line 101, in main
File “/home/hz/.local/lib/python3.8/site-packages/edk2toolext/base_abstract_invocable.py”, line 112, in Invoke
File “/home/hz/.local/lib/python3.8/site-packages/edk2toolext/edk2_invocable.py”, line 208, in ParseCommandLineOptions
Module = self.PlatformModule
AttributeError: ‘Edk2Update’ object has no attribute ‘PlatformModule’

Are you using standalone Ubuntu 18.04 or 20.04 as your host PC?

It seems the issue from your build environment.
Please refer to the wiki from the github and confirm if mono is installed correctly.

Hello, the problem has been solved, but I replaced the generated bin file with the bootloader’s bin file as requested, I think I should reopen a topic, you can close this topic. Another point I would like to make a suggestion, I see that many people have the reason why the network cannot connect to git, and I also have the same quesion。The same network, sometimes good and sometimes bad, I hope you can find out what the specific reason is

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.