Random "Unspecified launch Failure"


As far as I know, “Unspecified launch Failure” is typically related to a “segment fault”. However, I would appreciate if anybody could tell me if this error can be caused by any other reasons.

Here is what I do:

I have two kernels: kernel 1 and Kernel 2 that are executed one after the other in a loop.

Sometimes I run the code and everything works as expected. No error appears. Unfortunately, one every 3 or 4 times, I execute the code and I randomly get the “Unspecified launch failure” when trying to launch Kernel 2 on the first iteration of the loop. The code is absolutely deterministic, and there is nothing random, so I should always get the same result after Kernel 2. This, in fact, happens when the error does not come up.

Trying to find the error, I even removed the contents of Kernel 2 and made it an “emtpy kernel”. This ruled out the “segment fault”. However, the behavior is the same, randomly I get “Unspecified launch failure”.

There only special thing about my program is that I use p/invoke from C# to invoke C++ methods that contain these two kernels.

The C# program is single threaded.

Would it be possible that the “Unspecified launch Failure” is caused by the C# C++ interop?



Did you debug your program? Run your program a few times in debug mode. Most probably, some variables are not initilized.