Reboots while downloading the jetson-voice demo docker


I am trying to pull the jetson-voice docker from ngc, but the device is rebooting upon downloading or sometimes Extracting the 6GB layer.

I tried several times, but same issue all time.

I have 64GB sdcard and enabled 16GB of SWAP with free space available of 20GB.

I also tried combinations of the nvpmodel’s with jetsonclocks
Please let me know, if this is a HW issue.

Hi @ashokc344w, if you free up additional space on your SD card, is it able to download/extract the image?

Alternatively, if you are using the NX devkit, you might want to try using an M.2 NVMe and move your docker data directory over to it. You can move your docker data dir by having your M.2 drive auto-mounted on boot (via fstab) and adding a line like this to your /etc/docker/daemon.json configuration:

"data-root": "/your/desired/path",

You would then want to reboot or restart the docker service for the changes to take effect. You can check that the docker data dir is indeed what you want by running sudo docker info.

Hi @dusty_nv,

Thanks for the reply.

I don’t have the M.2 NVMe yet in my NX devkit.

Instead, can I use the USB3.0 drive ?

I tried increasing the SWAP to 32 GB using the USB3.0 pendrive. Now SDCARD free space is 30GB, and it still reboots while downloading.


Yes, you could use USB 3.0, sure.

Are you able to download other containers without it rebooting? Like others from the multi-container demo or l4t-ml.

@dusty_nv, using a data path to a new usb3.0 pen drive solved the issue.


BTW, i thought, this will have the TTS demo but couldn’t find.

Can you please let me know, if there is any TTS demo ?