REDHAT freeimage is not set up correctly

I have a similar problem to what is shown in this topic: FreeImage is not set up correctly. Please ensure FreeImae is set up correctly

where running the setup for cuDNN gives a warning:
“WARNING - FreeImage is not set up correctly. Please ensure FreeImage is set up correctly”

I am using redhat, not ubuntu and the suggested libraries to install ‘do not exist’ when I tried on redhat.

I tried following these install directions to install freeimage:
https://centos.pkgs.org/7/epel-x86_64/freeimage-3.17.0-4.el7.x86_64.rpm.html

After installation I still get the same warning and the run file is not created.

Any help is appreciated!

HI @Kevin1111
Just wanted to check if you followed tar based installation approach since the Debian installation package applies to Ubuntu 16.04, 18.04 and 20.04.
https://docs.nvidia.com/deeplearning/cudnn/install-guide/index.html#installlinux-tar

Thanks

1 Like

No I used the RPM instructions Installation Guide :: NVIDIA Deep Learning cuDNN Documentation. I don’t know if it matters, but I will try the tar based instructions today to see if that works.

After reading through the instructions again I noticed the following line suggest this verification test that I am trying to complete is only for debian packages. I guess there is no verification method for redhat?

2.4. Verifying The Install On Linux
To verify that cuDNN is installed and is running properly, compile the mnistCUDNN sample located in the /usr/src/cudnn_samples_v8 directory in the Debian file.

Hi @Kevin1111,
Verification process will almost remain same. You just need to build and run one of the provided samples in order to verify the installation.

Thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.