Registry URLs not working - omni.kit.registry.nucleus

Hi!

I’m developing an application and I’d like to include in the extension manager all the extensions that are part of USD composer and USD Presenter. I have add those registries in my .kit file under settings.exts."omni.kit.registry.nucleus":

[settings.exts."omni.kit.registry.nucleus"]
registries = [
    { name = "kit/default", url = "omniverse://kit-extensions.ov.nvidia.com/exts/kit/default" },
    { name = "kit/sdk", url = "omniverse://kit-extensions.ov.nvidia.com/exts/kit/sdk/${kit_version_short}/${kit_git_hash}" },
    { name = "kit/usd", url = "omniverse://kit-extensions.ov.nvidia.com/exts/kit/usd/nv-usd/22.11/merge_pxr_22-11-py310" },
]

But it doesn’t work, the extensions are not visible in my extension manager and I got the warning message :
[Warning] [omni.client.plugin] Tick: discovery: Could not resolve host name "kit-extensions.ov.nvidia.com"

It was working before, so it seems that these URLs are no longer valid. Would it be possible to have the new one, or is there a place where they are listed?

Thanks,
Félix

Hi, you can try putting the following registries: https://github.com/NVIDIA-Omniverse/kit-project-template/blob/main/source/apps/my_name.my_app.kit#L37

Those are the public registries we put extensions from Composer to. It might also be important to use the same version of kit: https://github.com/NVIDIA-Omniverse/kit-project-template/blob/main/tools/deps/kit-sdk.packman.xml#L3

1 Like

Thanks, but I also need the extension for USD Presenter.

I’ve added the registries provided by your link but they don’t cover USD Presenter extensions since I got the Failed to resolve extension dependencies for omni.kit.markup.core which I want to enable in my application. Do you also have the URL of the USD Presenter registry? Thanks.

USD Presenter was not yet released using our public extension registry. All extensions it has are packaged into it. You can only manually copy them from it (or point as an extension search path to it, with --ext-folder or in kit file where extscache dir is added).

1 Like

Ok thanks !

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.