Regression from 440.82/440.100 to later X driver versions - mult-display fails to init & segfaults Xorg

I’ve got an RTX 2080 with 4 separate heads, and yes I know I’m weird for running my setup like this, but this is how it’s worked in X Windows for decades. Yes, I like having separate screens that I can’t drag windows between. Yes, we’ve already established I’m weird.

I’ve actually had this problem for a while and was sticking with 440 for a super long time, but last night I tried to do an OS update and it broke X by upgrading my nvidia drivers. So here’s full detail with X running in debug mode, etc.

Section "ServerLayout"
    Identifier     "quad"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" LeftOf "Screen0"
    Screen      2  "Screen2" LeftOf "Screen1"
    Screen      3  "Screen3" LeftOf "Screen2"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"

That’s my normal setup, and under 450 or later, only one of the four monitors lights up in “quad” layout – oddly enough, the 3rd monitor (screen2); the rest are dark. X Windows (xrandr, xdpyinfo) think the rest of the displays are lit up and active, but there’s nothing on the screen.

If I try to individually run a single monitor, (screen2) it works. If I try to specify a two-display layout, Xorg segfaults.

[edit: found sensitive info in my log dumps, removed my log uploads, will update later]

Can you please upload your xorg.conf, Xorg.0.log, and output of coredumpctl info? If you’re concerned about sensitive information in logs you can email or send your logs directly to me.

@aplattner I guess DM me your e-mail address?

It’s just, it’s not hard to guess. :)

Sent, thanks. And happy cake day? :)

Heh, thanks. I didn’t realize the new forum had a cake day feature.