Problem with multiple x-screens since driver-version 435 (manjaro,RTX-2060)

hello there,
driver 435 and 440 wont allow me to configure multiple xscreens (as in chapter 14 of documentation) anymore
…works well until version 430, but above 430 the second x-screen is ignored…

the Xorg.0.log throws the following errors:

[ 7.539] (EE) NVIDIA(G0): GeForce RTX 2060 (GPU-0) already has an X screen assigned;
[ 7.539] (EE) NVIDIA(G0): skipping this GPU screen
[ 7.539] (EE) NVIDIA(G0): Failing initialization of X screen

im on manjaro linux using a RTX-2060 card
…any ideas what is wrong?

greetings and thanks,

nvidia-bug-report.log (582.8 KB)

Option “AllowNVIDIAGPUScreens”
set which is for render offload on optimus systems. Please remove it since then only one gpu screen per gpu is allowed.
Furthermore, please remove
since it defines yet another config.

oh hi, thanks for the reply!
i did all that… (removed 90-mhwd.conf and AllowNVIDIAGPUScreens) unfortunately it didnt help :-(
still the same error msg in Xorg.0.log. i attached the new nvidia-bug-report…

thanks and greetings,

nvidia-bug-report.log (576.2 KB) log

also contains it, please remove, try again.

hmm, ok did that… no, still same problem :-(
attached another log…
thanks, florian
nvidia-bug-report.log (626.2 KB)

I think the problem here is not necessarily the AllowNVIDIAGPUScreens option itself, but the fact that it requires a ServerLayout section to specify it. There’s a known issue with the X server where it will prefer a server layout it finds in xorg.conf.d/* over one you specify yourself in /etc/X11/xorg.conf. So even though your layout named Layout0 has two X screens, the server is using the one named layout that it’s finding in /usr/share/X11/xorg.conf.d/10-amdgpu-nvidia-drm-outputclass.conf that has an implicit one-screen layout. This causes the server to create a GPU screen for the other Device section you specified in xorg.conf.

I think you’ll need to delete the ServerLayout sections in /usr/share/X11/xorg.conf.d/* before your custom layout will be used. Alternatively, you should be able to start the X server with the -layout Layout0 option to choose your layout explicitly.

A future driver release will enable AllowNVIDIAGPUScreens by default on xserver 1.20.7 and newer so hopefully this problem will go away relatively soon.

wow, removed all ServerLayouts except mine and… indeed that worked :-)

thanks a lot!