Removing BPMP serial entry causes kernel panic

We are using a Jetson TX2 NX with a custom carrier board and I am attempting to enable ttyS2 (UART3/UARTC) to be used for communication with a microcontroller. I enabled it in the device tree and I was able to transmit on it with no issue. I was however having errors on the receive side and I saw TX2 NX RS232 Communication Problem. I tried to follow these steps, but when I flash the bpmp-fw-dtb, it causes a kernel panic

I also attempted to just change the port from 3 to 7, but it caused the same issue. I tried both the partial flash recommended in the 232 question and a full build & flash.

I am wondering what caused this lockup, and how to disable/move the bpmp terminal without causing boot issues

Hi user122610,

If you flash the original bpmp fw w/o any change, does your board could recover?

Do you mean that you refer to the modification in the following thread?
TX2 NX RS232 Communication Problem - #14 by JerryChang

What’s your current Jetpack version in use?
Please also provide the full serial console log for further check.

Flashing the original does recover. I was able to just comment out the line has_input and I can boot without issue and it seems to have turned off the bpmp console.

I am on R32.6.1, and I am unable to get the serial log. I have disabled it so I can use all 3 UATRTs

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.