(REOPEN) Replace UEFI boot splash screen/logo -- Custom Boot Logo Not Showing

Hello

I am reopening one issue already discusses:
this: Replace UEFI boot splash screen/logo (Jetpack 5.0.1 / R35.1) - #23 by hetfood6
And this:
Custom boot logo not showing

One issue that was closed because of the 14 days lapse of time, but not confirmed that it was solved.

After following your suggestions at the posts, using this at orin nano dev kit:
edk2_docker edkrepo clone nvidia-uefi NVIDIA-Platforms r35.4.1-updates

We conclude that release version doesn’t work, but debug version uefi shows the logo.

We’ve got the same issue, EXACTLY, already commented and even showed at the videos you’ll found at my links. Even using our images (so the problem were not the images) that is the only modification. Can you reproduce the issue? We were going to debug to find explanation inside uart messages, but debug version works. We don’t get it but it is what it is.

Hi masip85,

Are you working with loic.boileau or hetfood6?

Do you reproduce the issue on the devkit or custom board?

Are you using Jetpack 5.1.2(R35.4.1) currently?

Yes, that version downloaded yesterday.

Yes, orin nano 8gb dev kit.

Could you verify with r35.4.1 instead of r35.4.1-updates?

edk2_docker edkrepo clone nvidia-uefi NVIDIA-Platforms r35.4.1

That was our first attempt. We only tried release version, with same black screen results.

Okay, let me reproduce it locally and will update to you once there’s any result

1 Like

Please apply the following patch to check if it could help for your case.
fix(t234): do GOP console registration every boot · NVIDIA/edk2-nvidia@8e74c92 · GitHub

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.