Replacing old cboot with new customised cboot

Hi ,
I am trying to add a custom cboot.bin file to my nvidia-xavier-nx-development-kit(SD)
The steps i followed are
1)modified cboot by adding new print statements
2)compiled and build cboot according to the cboot readmefile
3)replaced the cboot_t194.bin file in bootloader dir
4)used flash.sh script for flashing cboot to the devkit.
cmd : sudo ./flash.sh -k cpu-bootloader ./bootloader/cboot_t194.bin jetson-xavier-nx-devkit mmcblk0p1

i am getting the error
[ 10.7798 ] Writing partition secondary_gpt with gpt_secondary_3_0.bin
[ 10.7800 ] […] 100%
[ 10.7814 ] 000000000d0d0001: o initialize partition table from GPT.
[ 79.1780 ]
[ 79.1780 ]
Error: Return value 1
Command tegradevflash_v2 --pt flash.xml.bin --create

  • chkerr ‘Failed flashing t186ref.’
  • ‘[’ 1 -ne 0 ‘]’
  • ‘[’ ‘Failed flashing t186ref.’ ‘!=’ ‘’ ‘]’
  • echo ‘Failed flashing t186ref.’
    Failed flashing t186ref.
  • exit 1

in the host and error

       k_ebugfs initiaized                                            

dbg ailed to register PTO c1
cdbufs iizedietri 81o i 281
pg_euf ntaieitaie
eugaeeiiizedliil_debugfs_init: /rmvd_cpu: aerildbg_init: /dd_fiedbgfilzenilized
intnaget
eterblgpio_rvrgse:r’iatga4i-o’die
[5.5I egalc939_init: i2c bus: 1, slave add: x6[15.6] W> fet53
[0154.373 > ethdie_phanlfo_dt:fietgtnd opaiblenpt91.7.3> tgrabl_tca9539_init: 4
[14400] W_driver_phandle_from_dt: failed to get node with compatible nxp,tca9539
[05.5 > CU iiaCre niaize
[015 IR0400PDR: 000[152I hip vion : A02P[1446] I Bot-deic:Q[.2]IBt_evie QIFAS tz
[548 >QSPI lsie=3 05.55]I si intalzscessful[0.6] >qp lah0pr ce = boot args
[0154.460] IFound sdcar.4] Ieling ‘vdd-sdmmc1-sw’ regulator
[0154.471] I> regulator 'vdd-sd1-salead enld
[0154.699] I> sdmmc SDR mode
.75 >Fud4 aiinsiQSIFAH(isac )ternr
[14.2] >UBcngrto ccs
[58I>QP:Erasngetr evie storage info
[0225.215] W> Cannot find any partiinar0030
0.5]E> 3SRE: l
in the serial console
What am i doing wrong?
Thanks in advance

No need to add the bootloader binary path.

Thanks Wayne
now i am getting this error:
Error: Return value 6
Command tegradevflash_v2 --write cpu-bootloader 1_cboot_t194_sigheader.bin.encrypt

  • chkerr ‘Failed to flash/read t186ref.’
  • ‘[’ 1 -ne 0 ‘]’
  • ‘[’ ‘Failed to flash/read t186ref.’ ‘!=’ ‘’ ‘]’
  • echo ‘Failed to flash/read t186ref.’
    Failed to flash/read t186ref.
  • exit 1

How about this command?

sudo ./flash.sh -r -k cpu-bootloader jetson-xavier-nx-devkit mmcblk0p1

I tried this cmd but still getting the same error.Is is because of wrong partition?Should i use any other partition other than mmcblk0p1?

mmcblk0p1 is not related to cboot. No need to worry about it.

Please try if doing full flash can flash or not.

OK!!
How to do that?
Thanks

Just remove -r and -k and partition name. Didn’t you flash the board before?

BTW, this is jetson AGX forum. Is your board NX or AGX?

It’s Xavier NX…Sorry for the posting in this page…

Yes I did it using etcher .

sudo ./flash.sh jetson-xavier-nx-devkit mmcblk0p1

This is full flash command. Full flash means the whole board will get flashed in addition to cboot.

It’s ok. I have moved it to NX forum.

Getting this when using full flash
tError: Return value 1
Command tegradevflash_v2 --pt flash.xml.bin --create

  • chkerr ‘Failed flashing t186ref.’
  • ‘[’ 1 -ne 0 ‘]’
  • ‘[’ ‘Failed flashing t186ref.’ ‘!=’ ‘’ ‘]’
  • echo ‘Failed flashing t186ref.’
    Failed flashing t186ref.
  • exit 1

and this in console

[0140.216] I vid rl
[2I> o-evc:QP[14.223 Bodvice: QSI_LASH ntne
040228> QIsurrae 20400 [10quetrte fz
s
[0140.] Iound sdcard
[14025 regltorvddsmmc-w aray eal=
[0140.497] I> Found 47 partitions in QSPI_FLASH (inariin n CAD(ntac )
0456]I ybo0
[0140.507] It.7] Io[0140.578] I> Populate storage info
[0140.602] I> Erasing device 3: 0
[0142.606] I> Writing[0211.004] W> Cannot find any pa004 >NVE:Fidt ntiliz rito .

Could you attach the whole flash log into a text file and attach that text file? I don’t think this is flash script problem, more like your host environment has something wrong.

BTW, the log from your uart console seems out of order. Could you check if you open two uart console in the same time?

flash_log (45.9 KB)
console_log (9.5 KB)
Attaching flash log and serial console log,
I restarted serial console now it’s working fine

Hi,

Can you go back to default case and flash the board? I mean use our default cboot binary instead of yours. If it can flash under such case, then we need to check what happened to your cboot binary.

Also, do you have to use rel-32.5.1? Is it okay to move to rel-32.6? This is to prevent some bugs that we already resolved before.

can you please provide the download link?

How did you get your 32.5.1 BSP? Just use the similar method to get the rel-32.6.

Hi I Downloaded Latest BSP and tried flashing and i think i am getting the same error.
Attaching the log file.
Thanks
flash_log2 (55.7 KB)