RmInitAdapter failed!

I have problem with RTX 2080Ti:
nvidia-smi -q
return “No devices were found”
In dmesg log:
NVRM: GPU:0000:02:00.0 RmInitAdapter failed! (0x23:0x65:1417)
NVRM: GPU:0000:02:00.0 rm_init_adapter failed, device minor number 0
full log info is in attachment
nvidia-bug-report.log.gz (99.9 KB)
I checked several nvidia-drivers (470, 495, 460), Linux distros (Debian, ubuntu, lubuntu), two pcie ports and various kernel options (acpi=off, noapic, pcie_aspm=off, rcutree.rcu_idle_gp_delay=1, mem_encrypt=off) with no effect.
Meanwhile nouveau driver works fine.

Most likely broken. Please check for a bios update, check if it works in another system, if nothing helps, replace.

Yes, it was worked in other computer (card was correctly detected by nvidia-smi).

Ok, then please check for a bios update and check if you can lower the pcie gen in bios settings. Do you use any kind of riser to connect the gpu?

GPU is connected directly to MoBo slot. I checked all pcie gens (1,2,3, and 4 default was auto) - no changes.
There is newest BIOS for MoBo in change log is only (https://www.gigabyte.com/Motherboard/TRX40-AORUS-MASTER-rev-10/support#support-dl-bios):

  • Update AMD AGESA
  • Add Re-size bar option for AMD Smart Access Memory support

Is any of above relevant to the problem? Is it worth to try/risk new BIOS?

New AGESA versions often fix specific pcie incompatibilities.

BIOS update done - no changes :(

I don’t really have an idea besides damaged gpu or damaged mainboard. Does it work running Windows on that system?

I dont have access to Windows.
Damaged GPU? But the card was worked on other system with nvidia drivers.
Damaged MoBo? But it works in text-mode and in graphical mode with nouveau.

One difference between nouveau and the prop. nvidia driver is nouveau only supports minimal clocks. While the nvidia driver throttles up the clocks as soon as the Xserver starts which is when your system breaks. So nouveau is not an indicator for sane hardware, it also runs to a degree on broken systems.

Well it is nothing common with X, I have problem in text-mode, nvidia-smi cannot detect GPU. Is there anything more what can I do more to diagnose the problem?

Download Windows, install, test.