2080RTX ti not detected by nvidia-smi (Manjaro, 440xx)

Hi, I am having a machine with two nvidia cards (1080 and 2080ti). Initially both the cards worked fine but after an upgrade to Manjaro linux, I could not get nivida-smi to detect 2080ti. nvidia-smi only shows 1080 even though infx -G utility lists both the cards. Could you please help me with this?
Manjaro linux, Kernel 5.4, Nvidia driver version 440xx.

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post. You will have to rename the file ending to something else since the forum software doesn’t accept .gz files (nifty!).

nvidia-bug-report_gz.log (357.0 KB)
Please find the log.gz file attached.

Looks broken:
[ 14.086017] NVRM: GPU 0000:01:00.0: RmInitAdapter failed! (0x26:0x65:1227)
The GPU fails to initialize, please check for properly connected power connectors, reseat the card in its slot, check in another system for a general hardware failure, RMA.

Hi generix! Thanks for your reply. I tried shifting the gpu to another slot and ran it alone to ensure it has adequate power supply. I still face the same RmInitAdapter issue. Is there any software fix to that error?

No, it’s broken. RMA if possible.