NVRM: RmInitAdapter failed! with Gigabyte GTX 750 on Kubuntu and Arch

Hi guys,

I’m trying to get the GTX 750 to work, but all I’m getting is

NVRM: RmInitAdapter failed! (0x26:0xffffffff:1218)
NVRM: rm_init_adapter failed for device bearing minor number 0
NVRM: nvidia_frontend_open: minor 0, module->open() failed, error -5

and either a blinking cursor at the top left or a garbled screen.

I’ve tried the following things:

  1. Use my archlinux install with nvidia-340
  • no graphics, tried also to boot with acpi=noirq, noapic
  • boot with nolapic and acpi=off results in a very unresponsive system or a non-accessible system
  1. trying it on a recent Kubuntu 14.10 Development Version.
  • drivers from the xorg-edgers PPA – didn’t work
  • delete the drivers again and then
  • use the install-script from the nvidia website
    But no matter what I’m still getting the above error. And I need to boot with “nomodeset” to be able to access the systems through the console.

My PC runs totally fine with my old (ATI HD 4550) graphics card.
The NVIDIA card also was successfully tested in a Windows-PC.

And what also was obvious: The fonts starting from the BIOS startup screen look smoother with the old card.

Is it possible that my PSU causes trouble because it is rather old and I needed to plug it in the mainboard through a 20-to-24pin adapter?

Please tell me if you need further information.

The bug-report-script output can be seen here:
The installer log is here:

I included the files as a link because I didn’t see where I can attach them.

Thanks in advance!

Did you install the driver manually on Arch Linux or did you use the package from the repos?

I had installed them from the repos.

But I’ve tried it now manually and there’s nothing different as far as I can see (at least no image).

Again the logs:
nvidia-bug-report-arch.log.gz (45.2 KB)
nvidia-installer-arch.log (190 KB)

Can you check by interchanging PCIe slots ? Also do you have same other card to test ? Is this happening with latest OS only?

1: I’ve put the card into the PCIe-x4 slot – no change, no image, the same NVRM messages as before.
2: If I plug my old ATI HD 4550 into the x16 slot the system works totally normal and I can login into my desktop.
3: I only bought the NVIDIA card recently, so I’m trying to get it running for the first time on Linux.

I’m not sure if this has anything to say:

  • Arch shows
    NVRM: RmInitAdapter failed! (0x26:0xffffffff:1218)

    whereas Kubuntu shows

    NVRM: RmInitAdapter failed! (0x26:0xffffffff:1215)
  • Arch shows (with manually installed driver 340.23) a screen filled with cursors (one of them is blinking) whereas Kubuntu (with manually installed driver 343.22) only shows a black screen

Oh and the NVIDIA was tested successfully in a Windows-PC which doesn’t have a GPU inside the CPU. So I would say the problem is neither the NVIDIA card nor my PCIe slot.

Are you saying the same Gigabyte GTX 750 card working fine on Windows ?

Yes, that’s right.

It was tested in a system with an i5-3350P. So there’s no GPU except the GTX 750.
There was an image and games like torcs could be played at highest settings with 60fps.

Tracking this issue internally Bug 200040837:NVRM: RmInitAdapter failed! with Gigabyte GTX 750 on latest KUbuntu Utopic Unicorn and Arch on GTX 750

Please get the below details :

*** From log monitor is not listed out ,so please get the monitor make and model.

*** Vbios version of card and whether it is over clocked or stock vbios.

You’ll also want to make sure nouveau is disabled; I do see its X driver being loaded in the Xorg log

Thanks for your reply, sandipt!

My monitor is a ViewSonic VA2349S connected over DVI.

I failed getting the vbios version. It’s stock in every regard. Unpacked and instantly plugged into the PC.

I tried the following things on arch:

# cat /proc/driver/nvidia/gpus/0000:01:00.0/information                                                                                                   :(
Model:           GeForce GTX 750
IRQ:             44
GPU UUID:        GPU-????????-????-????-????-????????????
Video BIOS:      ??.??.??.??.??
Bus Type:        PCIe
DMA Size:        40 bits
DMA Mask:        0xffffffffff
Bus Location:    0000:01:00.0
% sudo nvclock -d -s
m=0 n=0 p=0
m=0 n=0 p=0
Card:           Unknown Nvidia card
Card number:    1
m=0 n=0 p=0
Memory clock:   -2147483.750 MHz
m=0 n=0 p=0
GPU clock:      -2147483.750 MHz
% sudo nvclock -i
It seems your card isn't officialy supported in NVClock yet.
The reason can be that your card is too new.
If you want to try it anyhow [DANGEROUS], use the option -f to force the setting(s).
NVClock will then assume your card is a 'normal', it might be dangerous on other cards.
Also please email the author the pci_id of the card for further investigation.
[Get that value using the -i option].

Is there some other way to get the vbios version?

Regarding the nouveau driver:
It wasn’t ever installed on arch afair. You see it’s not loaded in the second log I posted in message #3.
It was installed on kubuntu but blacklisted to not be loaded (see attached Xorg-log).
So I guess the nouveau driver can’t be a problem.

FYI: In the next days I’ll plug the GPU in the Windows PC where the card was tested and try to get it to work under Linux there. Maybe this will give some clues on what’s going wrong. Is there anything special I should check? Otherwise I would just collect the usual logs.

Just reinstall driver and run nvidia-smi -q . Also connect same card on another system and test.

celsion, Any update about testing : "FYI: In the next days I’ll plug the GPU in the Windows PC where the card was tested and try to get it to work under Linux there. Maybe this will give some clues on what’s going wrong. Is there anything special I should check? Otherwise I would just collect the usual logs. "

Hi sandipt, sorry for the delay.

I tested the GPU in the Windows-PC:
First on Windows again because I saw, that the Mainboard also has a GPU on it, but when I deactivated the NVIDIA GPU, there was a clear difference in behaviour.
Conclusion: NVIDIA GPU works on Windows

Then I plugged in my HDD and installed a fresh Kubuntu 10.10 and I got it to work!
It was a big difference to my system because even with the LiveCD I was able to get rudimentary graphics (vesa) whereas on my system I only got a black screen. I needed to plug in my old graphics card to be able to install Kubuntu on my system.
Conclusion: NVIDIA GPU also works under Linux on that machine.

But still no change on my PC:
I tried out 3 different (but quite old) PSUs. One 400W and two 300W.
The only parts connected are:
PSU, Mainboard, CPU, GPU, RAM, 1 HDD.

I’ll get a new PSU next week… Maybe the GPU draws too much power from the PSU?

I’ll attach the nvidia-smi -q which gave me the vbios version on the Windows-PC.

VBIOS Version                   :

nvidia-smi–q.log (4.96 KB)

Hi Celsion,

Are you still facing the same problem after changing the PSU.
Which older Nvidia gpu is working in your older system.

Hi Jawandson and sandipt!

Yes, the problem wasn’t solved with the new PSU.

But yesterday I updated the BIOS and now the GPU works :)
I wish I’d have thought of this earlier …

So, this issue is resolved now.
Thanks for your help!

Greets, celsion