can not install GT 730 on Kubuntu 14.04

Kernel is 3.13-46, Kubuntu 14.04.1

I’ve been battling for 2 days now with this card. well 9 hours+ today about 3 hours and i can’t get the card to work.

today i made sure i started from scratch all cleared form previous attempts.

  1. inserted card
  2. boot with nomodeset - computer get’s normally to desktop with poor resolution 640x480
  3. i move to TTY1 & stop lightdm just in case
  4. add xorg-edgers PPA
  5. install nvidia-346
  6. reboot
  7. splash works in vesa, then it all goes black. i can not get to TTY.

some suggested it is the monitors faults, so i attached a 4 year old TV and same thing happened.

i barely managed to get to TTY after several reboots to be able to uninstall the driver.

i later went to check the logs and here are some interesting log entries relating to nvidia.
Mar 23 17:41:21 tatie-desktop kernel: [ 31.005799] NVRM: RmInitAdapter failed! (0x26:0x65:1292)
Mar 23 17:41:21 tatie-desktop kernel: [ 31.005814] NVRM: rm_init_adapter failed for device bearing minor number 0
Mar 23 17:41:21 tatie-desktop kernel: [ 31.005847] NVRM: nvidia_frontend_open: minor 0, module->open() failed, error -5

Mar 23 17:41:21 tatie-desktop kernel: [   31.005814] NVRM: rm_init_adapter failed for device bearing minor number 0
Mar 23 17:41:21 tatie-desktop kernel: [   31.005847] NVRM: nvidia_frontend_open: minor 0, module->open() failed, error -5
Mar 23 17:41:22 tatie-desktop kernel: [   31.846175] init: plymouth-upstart-bridge main process ended, respawning
Mar 23 17:41:22 tatie-desktop nvidia-persistenced: Failed to unlink socket: No such file or directory
Mar 23 17:41:22 tatie-desktop nvidia-persistenced: Failed to unlink PID file: No such file or directory
Mar 23 17:41:22 tatie-desktop nvidia-persistenced: Shutdown (1407)
Mar 23 17:41:22 tatie-desktop kernel: [   31.991914] nvidia 0000:02:00.0: irq 65 for MSI/MSI-X
Mar 23 17:41:22 tatie-desktop nvidia-persistenced: Started (1715)
Mar 23 17:41:30 tatie-desktop NetworkManager[830]: <info> (eth0): IP6 addrconf timed out or failed.
Mar 23 17:41:30 tatie-desktop NetworkManager[830]: <info> Activation (eth0) Stage 4 of 5 (IPv6 Configure Timeout) scheduled...
Mar 23 17:41:30 tatie-desktop NetworkManager[830]: <info> Activation (eth0) Stage 4 of 5 (IPv6 Configure Timeout) started...
Mar 23 17:41:30 tatie-desktop NetworkManager[830]: <info> Activation (eth0) Stage 4 of 5 (IPv6 Configure Timeout) complete.

xorg

[    31.941] 
X.Org X Server 1.15.1
Release Date: 2014-04-13
[    31.941] X Protocol Version 11, Revision 0
[    31.941] Build Operating System: Linux 3.2.0-75-generic i686 Ubuntu
[    31.941] Current Operating System: Linux tatie-desktop 3.13.0-46-generic #79-Ubuntu SMP Tue Mar 10 20:08:14 UTC 2015 i686
[    31.941] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.13.0-46-generic root=UUID=3f43c7a8-003b-4564-9f0d-a7a4c0393e06 ro quiet splash xforcevesa
[    31.941] Build Date: 12 February 2015  02:49:46PM
[    31.941] xorg-server 2:1.15.1-0ubuntu2.7 (For technical support please see http://www.ubuntu.com/support) 
[    31.941] Current version of pixman: 0.30.2
[    31.941] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[    31.941] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    31.941] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Mar 23 17:41:22 2015
[    31.941] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    31.942] (==) No Layout section.  Using the first Screen section.
[    31.942] (==) No screen section available. Using defaults.
[    31.942] (**) |-->Screen "Default Screen Section" (0)
[    31.942] (**) |   |-->Monitor "<default monitor>"
[    31.942] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[    31.942] (==) Automatically adding devices
[    31.942] (==) Automatically enabling devices
[    31.942] (==) Automatically adding GPU devices
[    31.942] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    31.942] 	Entry deleted from font path.
[    31.942] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[    31.942] 	Entry deleted from font path.
[    31.942] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[    31.942] 	Entry deleted from font path.
[    31.942] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[    31.942] 	Entry deleted from font path.
[    31.942] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[    31.942] 	Entry deleted from font path.
[    31.942] (==) FontPath set to:
	/usr/share/fonts/X11/misc,
	/usr/share/fonts/X11/Type1,
	built-ins
[    31.942] (==) ModulePath set to "/usr/lib/i386-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[    31.942] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[    31.942] (II) Loader magic: 0xb779a6c0
[    31.942] (II) Module ABI versions:
[    31.942] 	X.Org ANSI C Emulation: 0.4
[    31.942] 	X.Org Video Driver: 15.0
[    31.942] 	X.Org XInput driver : 20.0
[    31.942] 	X.Org Server Extension : 8.0
[    31.942] (II) xfree86: Adding drm device (/dev/dri/card0)
[    31.944] (--) PCI:*(0:2:0:0) 10de:0f02:1462:8a9f rev 161, Mem @ 0xfd000000/16777216, 0xf0000000/134217728, 0xfa000000/33554432, I/O @ 0x0000ec00/128, BIOS @ 0x????????/524288
[    31.944] Initializing built-in extension Generic Event Extension
[    31.944] Initializing built-in extension SHAPE
[    31.944] Initializing built-in extension MIT-SHM
[    31.944] Initializing built-in extension XInputExtension
[    31.944] Initializing built-in extension XTEST
[    31.944] Initializing built-in extension BIG-REQUESTS
[    31.944] Initializing built-in extension SYNC
[    31.944] Initializing built-in extension XKEYBOARD
[    31.944] Initializing built-in extension XC-MISC
[    31.944] Initializing built-in extension SECURITY
[    31.944] Initializing built-in extension XINERAMA
[    31.944] Initializing built-in extension XFIXES
[    31.944] Initializing built-in extension RENDER
[    31.944] Initializing built-in extension RANDR
[    31.944] Initializing built-in extension COMPOSITE
[    31.944] Initializing built-in extension DAMAGE
[    31.944] Initializing built-in extension MIT-SCREEN-SAVER
[    31.944] Initializing built-in extension DOUBLE-BUFFER
[    31.944] Initializing built-in extension RECORD
[    31.944] Initializing built-in extension DPMS
[    31.944] Initializing built-in extension Present
[    31.944] Initializing built-in extension DRI3
[    31.944] Initializing built-in extension X-Resource
[    31.944] Initializing built-in extension XVideo
[    31.944] Initializing built-in extension XVideo-MotionCompensation
[    31.944] Initializing built-in extension SELinux
[    31.944] Initializing built-in extension XFree86-VidModeExtension
[    31.944] Initializing built-in extension XFree86-DGA
[    31.944] Initializing built-in extension XFree86-DRI
[    31.944] Initializing built-in extension DRI2
[    31.944] (WW) "glamoregl" will not be loaded unless you've specified it to be loaded elsewhere.
[    31.944] (II) "glx" will be loaded by default.
[    31.944] (WW) "xmir" is not to be loaded by default. Skipping.
[    31.944] (II) LoadModule: "glx"
[    31.944] (II) Loading /usr/lib/i386-linux-gnu/xorg/extra-modules/libglx.so
[    31.982] (II) Module glx: vendor="NVIDIA Corporation"
[    31.983] 	compiled for 4.0.2, module version = 1.0.0
[    31.983] 	Module class: X.Org Server Extension
[    31.983] (II) NVIDIA GLX Module  346.47  Thu Feb 19 18:14:56 PST 2015
[    31.983] Loading extension GLX
[    31.983] (==) Matched nvidia as autoconfigured driver 0
[    31.983] (==) Matched nouveau as autoconfigured driver 1
[    31.983] (==) Matched nvidia as autoconfigured driver 2
[    31.983] (==) Matched nouveau as autoconfigured driver 3
[    31.983] (==) Matched modesetting as autoconfigured driver 4
[    31.983] (==) Matched fbdev as autoconfigured driver 5
[    31.983] (==) Matched vesa as autoconfigured driver 6
[    31.983] (==) Assigned the driver to the xf86ConfigLayout
[    31.983] (II) LoadModule: "nvidia"
[    31.983] (II) Loading /usr/lib/i386-linux-gnu/xorg/extra-modules/nvidia_drv.so
[    31.983] (II) Module nvidia: vendor="NVIDIA Corporation"
[    31.983] 	compiled for 4.0.2, module version = 1.0.0
[    31.983] 	Module class: X.Org Video Driver
[    31.983] (II) LoadModule: "nouveau"
[    31.984] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[    31.984] (II) Module nouveau: vendor="X.Org Foundation"
[    31.984] 	compiled for 1.15.0, module version = 1.0.10
[    31.984] 	Module class: X.Org Video Driver
[    31.984] 	ABI class: X.Org Video Driver, version 15.0
[    31.984] (II) LoadModule: "modesetting"
[    31.984] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    31.984] (II) Module modesetting: vendor="X.Org Foundation"
[    31.984] 	compiled for 1.15.0, module version = 0.8.1
[    31.984] 	Module class: X.Org Video Driver
[    31.984] 	ABI class: X.Org Video Driver, version 15.0
[    31.984] (II) LoadModule: "fbdev"
[    31.984] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    31.985] (II) Module fbdev: vendor="X.Org Foundation"
[    31.985] 	compiled for 1.15.0, module version = 0.4.4
[    31.985] 	Module class: X.Org Video Driver
[    31.985] 	ABI class: X.Org Video Driver, version 15.0
[    31.985] (II) LoadModule: "vesa"
[    31.985] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    31.985] (II) Module vesa: vendor="X.Org Foundation"
[    31.985] 	compiled for 1.15.0, module version = 2.3.3
[    31.985] 	Module class: X.Org Video Driver
[    31.985] 	ABI class: X.Org Video Driver, version 15.0
[    31.985] (II) NVIDIA dlloader X Driver  346.47  Thu Feb 19 17:51:09 PST 2015
[    31.985] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    31.985] (II) NOUVEAU driver Date:   Thu Nov 7 14:56:48 2013 +1000
[    31.985] (II) NOUVEAU driver for NVIDIA chipset families :
[    31.985] 	RIVA TNT        (NV04)
[    31.985] 	RIVA TNT2       (NV05)
[    31.985] 	GeForce 256     (NV10)
[    31.985] 	GeForce 2       (NV11, NV15)
[    31.985] 	GeForce 4MX     (NV17, NV18)
[    31.985] 	GeForce 3       (NV20)
[    31.985] 	GeForce 4Ti     (NV25, NV28)
[    31.985] 	GeForce FX      (NV3x)
[    31.985] 	GeForce 6       (NV4x)
[    31.985] 	GeForce 7       (G7x)
[    31.985] 	GeForce 8       (G8x)
[    31.985] 	GeForce GTX 200 (NVA0)
[    31.985] 	GeForce GTX 400 (NVC0)
[    31.985] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    31.985] (II) FBDEV: driver for framebuffer: fbdev
[    31.985] (II) VESA: driver for VESA chipsets: vesa
[    31.985] (++) using VT number 7

[    31.989] (II) Loading sub module "fb"
[    31.989] (II) LoadModule: "fb"
[    31.989] (II) Loading /usr/lib/xorg/modules/libfb.so
[    31.989] (II) Module fb: vendor="X.Org Foundation"
[    31.989] 	compiled for 1.15.1, module version = 1.0.0
[    31.989] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    31.989] (II) Loading sub module "wfb"
[    31.989] (II) LoadModule: "wfb"
[    31.989] (II) Loading /usr/lib/xorg/modules/libwfb.so
[    31.990] (II) Module wfb: vendor="X.Org Foundation"
[    31.990] 	compiled for 1.15.1, module version = 1.0.0
[    31.990] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    31.990] (II) Loading sub module "ramdac"
[    31.990] (II) LoadModule: "ramdac"
[    31.990] (II) Module "ramdac" already built-in
[    31.990] (WW) Falling back to old probe method for modesetting
[    31.990] (WW) Falling back to old probe method for fbdev
[    31.990] (II) Loading sub module "fbdevhw"
[    31.990] (II) LoadModule: "fbdevhw"
[    31.991] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[    31.991] (II) Module fbdevhw: vendor="X.Org Foundation"
[    31.991] 	compiled for 1.15.1, module version = 0.0.2
[    31.991] 	ABI class: X.Org Video Driver, version 15.0
[    31.991] (EE) open /dev/fb0: No such file or directory
[    31.991] (WW) Falling back to old probe method for vesa
[    31.991] (II) NVIDIA(0): Creating default Display subsection in Screen section
	"Default Screen Section" for depth/fbbpp 24/32
[    31.991] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[    31.991] (==) NVIDIA(0): RGB weight 888
[    31.991] (==) NVIDIA(0): Default visual is TrueColor
[    31.991] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    31.991] (**) NVIDIA(0): Enabling 2D acceleration
[    44.090] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA GPU at PCI:2:0:0.  Please
[    44.091] (EE) NVIDIA(GPU-0):     check your system's kernel log for additional error
[    44.091] (EE) NVIDIA(GPU-0):     messages and refer to Chapter 8: Common Problems in the
[    44.091] (EE) NVIDIA(GPU-0):     README for additional information.
[    44.091] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA graphics device!
[    44.091] (EE) NVIDIA(0): Failing initialization of X screen 0
[    44.091] (II) UnloadModule: "nvidia"
[    44.091] (II) UnloadSubModule: "wfb"
[    44.091] (II) UnloadSubModule: "fb"
[    44.091] (EE) Screen(s) found, but none have a usable configuration.
[    44.091] (EE) 
Fatal server error:
[    44.091] (EE) no screens found(EE) 
[    44.091] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[    44.091] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    44.091] (EE) 
[    44.092] (EE) Server terminated with error (1). Closing log file.

dmesg

[   17.202354] nvidia: module license 'NVIDIA' taints kernel.
[   17.202360] Disabling lock debugging due to kernel taint
[   17.202563] type=1400 audit(1427128356.681:5): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/sbin/dhclient" pid=545 comm="apparmor_parser"
[   17.202573] type=1400 audit(1427128356.681:6): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/NetworkManager/nm-dhcp-client.action" pid=545 comm="apparmor_parser"
[   17.202578] type=1400 audit(1427128356.681:7): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/connman/scripts/dhclient-script" pid=545 comm="apparmor_parser"
[   17.203129] type=1400 audit(1427128356.681:8): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/lib/NetworkManager/nm-dhcp-client.action" pid=545 comm="apparmor_parser"
[   17.203140] type=1400 audit(1427128356.681:9): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/lib/connman/scripts/dhclient-script" pid=545 comm="apparmor_parser"
[   17.203395] type=1400 audit(1427128356.681:10): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/lib/connman/scripts/dhclient-script" pid=545 comm="apparmor_parser"
[   17.260930] nvidia: module verification failed: signature and/or  required key missing - tainting kernel
[   17.322014] init: cups main process (522) killed by HUP signal
[   17.322031] init: cups main process ended, respawning
[   18.032363] init: failsafe main process (602) killed by TERM signal
[   18.176030] hda-intel 0000:02:00.1: Codec #0 probe error; disabling it...
[   18.390524] type=1400 audit(1427128357.869:11): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/sbin/dhclient" pid=771 comm="apparmor_parser"
[   19.188032] hda-intel 0000:02:00.1: Codec #1 probe error; disabling it...

this is the motherboard - asrock 4core dual-sata2 R2.0 specs: http://www.asrock.com/mb/VIA/4CoreDual-SATA2%20R2.0/
this is the card: MSI Geforce GT 730 2GB N730-2GD3V1

i am not sure why but it seems form various messages as if the driver thinks i have optimus or something available. while there are both AGP and PCie slots available, i removed the currently used old ATI card before attempting to install nvidia. so there is onyl one GPU and that one is in PCIe. just to make it sure to the BIOS i selected PCIe as defautl GPU adapter in it’s settings.

Furthermore i have tried to boot into live session using 14.04.2 with newer kernel and the 15.04beta with an even newer kernel. both failed even using nomodeset with the message: ASPM could not configure common clock

i mean the opensource drivers should at least take it to the desktop as they do on installed Kubuntu.

to make sure i succesfully booted both DVD’s on another PC.

so any ideas? i read Chapter 8 common problmes. it mentions ACPI parameters, but i am not sure i will get far using them all over the place. is there a way to know exactly which parameter should be used?

would just like to add about debug report - desktop is not working os first method of creation is out.
upon blank screen I hit ctrl+alt+F1 -> entered login name and password and then sudo reboot and password. I had no view of screen however these commands should send the computer into reboot but they haven’t. it seems that upon blank screen even the LCI is actually not working. I will try to use SSH and see if I can connect to it like that. however the logs above should tell plenty.

plus If nouveu work (reverse engineered) NVidia ones should work even better right?

found a similar issue here: https://devtalk.nvidia.com/default/topic/776693/nvrm-rminitadapter-failed-with-gigabyte-gtx-750-on-kubuntu-and-arch/

user solved it by upgradeing BIOS. however my BIOS is supposedly already at max version and officially radeon 4xxx cards are supported. so pcie 2.0 cards. does this mean card is just not supported by the motherboard+linux combo?

Hi ,
i have the GT730 installed on openSUSE 13.3 ( Tumbleweed ) with Kernel 3.19.3 and driver 349.12 without
any problems.

case closed by returning the card to the vendor. troubleshooting could not be done as script can not be run. I suggest script is changed to run as log or on boot.

@bernasek - good for you. I believe my issue is BIOS or a setting in BIOS and possibly an unusual motherboard combined with the way kernel interacts with hardware. I am sure it would work well if I installed windows on this PC. it appears drivers want some optimus combo even when there is only one GPU available.