Ros-Deep-learning fps changing


I have been trying to change the frame rate, i have tried multiple things but the fps is still not changing, it keeps streaming on 30 fps. am using ros-deep-learning pkg with ROS melodic. please if you have any solution please let me know.

cmd: roslaunch ros_deep_learning video_viewer.ros1.launch input:=csi://0 output:=display://0

Please make sure the camera source supports 60fps and width, height, framerate are configured to fit the mode. And may add debug print to the source code to ensure the parameters are correctly set:
ros_deep_learning/src/node_video_source.cpp at master · dusty-nv/ros_deep_learning · GitHub

I want to reduce it to 10-20 fps, can you please elaborate more regrading the mode and debug print

@Hanzoo it will only change the framerate to modes that are supported in camera, but you can go into the video_input source and manually add the limiting (or use another ROS node to do it). Or you can go into jetson_utils and modify the GStreamer pipeline here:

I have tried, i might did something wrong, can u plz specify where I need to add the fps? and the syntax also in gstCamera 161. Also, how to change the mode?

@Hanzoo I would try adding a GStreamer videorate plugin to the nvarguscamerasrc pipeline:

or if it’s easier for you, in the video_source node, you can just slow down the calls to videoSource::Capture() with a sleep() after, or use some other ROS mechanism like this:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.