ros-kinetic-desktop

This will now build from source on the TX1. Tried it a week or so ago and had problems with a couple of the packages trying to use ninja without any ninja.build or ninja.rules files being generated. Generated the source again Fri night and now those two problems have been fixed and it builds just fine. Also google Cartographer will build on the TX1. A couple of libs you need to download and compile ceres-solver and eigen 3. Also lua5.2 which you can get with apt-get. Google lua install make sure you have all the parts installed or it will fail. Also add these two lines to your /etc/profile

export LUA_CFLAGS="-I/usr/include"
export LUA_LIBS="-L/usr/lib/aarch64-linux-gnu/ -llua -ldl"

Be sure to source /etc/profile after adding these. That should get you going. Anxious to try out this after reading about it all week on the social sites. Looks pretty sweet. Wondering if its from the self driving cars? Working on getting cartographer_ros working now. Still haven’t managed to get the Zed working yet. There is a 64-bit SDK now. But the zed_wrapper fails to build so far on my machine.

This setup is going on the rover and drone. Using a TK1 on the drone and a TX1 on the rover as companion computers with a pixhawk. MavRos handles the communications. Realsense camera and lidar on the drone. Zed and lidar on the rover.

Building ROS from source isn’t all that difficult. Just follow the instructions in the wiki. If you want it to install into the normal /opt/ros location you will need to add --install-space /opt/ros/kinetic to the build line. This can cause problems on Ubuntu so you might want to use the regular isolated build. However I’m thinking that the packages will be available at some point and it will be easy to reinstall everything via apt-get. So far with it installed at /opt/ros/kinetic I’ve had no problems building other packages as long as I use catkin_make_isolated instead of catkin_make. Minor issue if you want to get to work with ROS on the TX1 64 bit OS now.

Dan

Hi Dan

that sounds very encouraging and I am hoping to follow in your footsteps very soon.

What version of ROS are you compiling?

Thanks

Galto

Kinetic. Its the version recommended for wiley and xenial versions of ubuntu.

Dan

Just for grins I checked to see if an apt-get install works now. Sure enough and it resolves the problems I was having getting cartographer_ros to compile. So no need to go the source route now. Started thinking if they fixed the source install problems then maybe the packages were in the repos. A lot easier to deal with since the ROS files are now in the correct /opt/ros directory instead of being an isolated build.

Dan

Hi Dan

thanks for sharing this.

Cheers

Galto

Howdy

I upgraded my JTX1 to JP2.3 64b, and then I started installing ROS Kinetic as follows:

$ sudo update-locale LANG=C LANGUAGE=C LC_ALL=C LC_MESSAGES=POSIX

$ sudo sh -c 'echo "deb http://packages.ros.org/ros/ubuntu xenial main" > /etc/apt/sources.list.d/ros-latest.list'

$ sudo apt-key adv --keyserver hkp://ha.pool.sks-keyservers.net:80 --recv-key 0xB01FA116

$ sudo apt-get update

$ sudo apt-get install ros-kinetic-ros-base 

$ sudo apt-get install python-rosdep

But when I want to initialize rosdep, I am running into an issue:

$ sudo rosdep init

ERROR: cannot download default sources list from:
https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/sources.list.d/20-default.list
Website may be down.

I also noticed that I don’t have the /etc/ros directory

Any suggestions anyone?

Thanks

Galto

I ended up having to rehash the SSL certificate. Here’s an article, there’s a linked script to install ROS on L4T 24.2.1 :

Thank you Kangalow, I ran your script and now I got ROS kinetic, sweet!