ROS Indigo does not support Arm64 on JetPack 2.2

Has anyone been able to install Ros after installing Jetpack 2.2? The ros package is not found when I try to install it. This is for commands
sudo apt-get install ros-indigo-desktop
and
sudo apt-get install ros-indigo-desktop-full

I tried both the indigo armhf version and regular version with no luck. Help is appreciated. Thanks.

Not sure if the link helps http://wiki.ros.org/indigo/Installation/UbuntuARM ?

I already tried the instructions on that link. Does not work.

Hi i have quite the same problem on my TX1.
I just installed and flashed via Jetpack. But i have some errors when trying to install and downlaod ros.
First the apt-get update return a " duplicate entry " error in sources list.
more i cant find aswell the packages for ros " unable to locate ros-indigo-ros-base" or watever ros package.

The cpuinfo command is not clear tho on the result
and does the version floashed by jetpack is an Arch64 or an ARM64 version ?
thansk a lot

A couple of things:

  1. JetPack is the installer for L4T and supporting packages such as CUDA, OpenCV4Tegra and Visionworks. For the TX1, there is an option to install 32 bit (23.2) or 64 bit (24.1) versions of L4T. From your question, it seems that you installed L4T 24.1

  2. The 64 bit version architecture is referred to as aarch64, which is ARM 64 bit

To answer the original question, there are no current Debian packages to install ROS available for L4T 24.1, you have to compile it from source. Debian packages are what the ‘apt-get install’ command installs from. As you know, under the 32 bit L4T 23.2 version, there are packages available.

This should change over time as 64 bit ARM machines become more widely available. Note that it is likely non-trivial to compile ROS on 24.1, though it should be somewhat easier being able to run everything on board now as compared to cross compiling on a host PC.

Please do a search first! https://devtalk.nvidia.com/default/topic/937529/jetson-tx1/l4t-24-1-and-ros/ (Although this was even on the front page…)

This forum is already hard enough to keep track of >.<

@Kangalow: yes, non-trivial indeed!

I have just decided to work with the 32 bit version for now.
@RNZNobody: I read the link you posted, except the discussion was pre-Jetpack 2.2 and when I posted this issue, I mistakenly thought that this fact made a difference. My apologies if I made the forum hard to keep track of.

I’ve posted on the original topic, but I’ll repeat myself here just in case. If anyone managed to get ROS working on 24.1 it would be great if you could post some instructions. I will try to get the 64-bit version working this week, but if 32-bit is the only way to go for now it would be nice to make it clear to avoid wasting time with 64-bit.

Cheers

Just a quick update - source installation works, with Bare-Bones only sbcl is not found and you have to install it separately and add skip-keys.