ROS Indigo installation problem

The error message is “E: unable to locate package ros-indigo-ros-base”.

I’ve installed the Jetpack and the Grinch kernel and followed all the instructions on each of these tutorials:

http://myzharbot.robot-home.it/blog/software/myzharbot-ros/ros-installation-nvidia-jetson-tk1/
http://wiki.ros.org/indigo/Installation/UbuntuARM
http://jetsonhacks.com/2015/05/27/robot-operating-system-ros-on-nvidia-jetson-tk1/

I’ve tried:
Installing a different distro (Jade)
Run sudo apt-get update
Made sure all the repositories are enabled.

It’s always the same error. Is it because all of these are for the TK1 ? I thought these would work for the TX1 as well because of the same instruction sets. Has anyone installed ROS on the TX1? Help.

Hi Grom93,

You may do a search in
https://devtalk.nvidia.com/default/topic/937529/jetson-tx1/l4t-24-1-and-ros/

Or post your issue there to see if other people met similar issue.

Hope this can help on your case.

Cheers

The TK1 is ARMv7 instruction set. TX1’s ARMv8-a is a different 64-bit instruction set. ARMv8 is the 32-bit compatibility to ARMv7 and provided the CPU is in 32-bit mode it can work with ARMv7/armhf. However, package managers are responsible for showing what is available, and unless you have marked compatibility packages from armhf/ARMv7 as something to allow, it won’t tell you. In a similar way, it isn’t unusual for an x86_64 machine to not show you 32-bit i686 compatibility packages unless you’ve stated you’re interested in this. There may still be some compatible packages under armhf which do not show up even if you’ve said to show ARMv7 packages.