driver_base ROS (Robot Operating System) on Jetson TK1

Hello all. I’ve just found someone to fix the OpenCV problem with ROS on the Jetson TK1 board, thanks to
@L0g1x . However, I tried to catkin_make, and I have another issue:

CMake Error at /opt/ros/indigo/share/catkin/cmake/catkinConfig.cmake:75 (find_package):
Could not find a package configuration file provided by “driver_base” with
any of the following names:

driver_baseConfig.cmake
driver_base-config.cmake

Add the installation prefix of “driver_base” to CMAKE_PREFIX_PATH or set
“driver_base_DIR” to a directory containing one of the above files. If
“driver_base” provides a separate development package or SDK, be sure it
has been installed.
Call Stack (most recent call first):
mst_position/CMakeLists.txt:7 (find_package)

– Configuring incomplete, errors occurred!
See also “/home/ubuntu/enterprise_ws/build/CMakeFiles/CMakeOutput.log”.
See also “/home/ubuntu/enterprise_ws/build/CMakeFiles/CMakeError.log”.
make: *** [cmake_check_build_system] Error 1
Invoking “make cmake_check_build_system” failed

Where mst_position is one of our packages. I think it is another ROS problem. Not sure how to solve this one. Should I just download the driver_base package from ROS (probably on github) and install it that way, or is there another way to go about fixing this issue? Any help would be great. Thanks!

yup! just install driver-base. On the ARM indigo install page, they instruct you to only install the

ros-indigo-ros-base

which doesnt contain alot of the stuff like for say,

ros-indigo-full-desktop

would.

Just do

sudo apt-get install ros-indigo-driver-base

(im assuming this is already in the ARM build farm since i dont use it myself)

Thanks! I already solved it. I just downloaded the source code from git and threw it into my catkin workspace (in the src folder) and it stopped complaining. Thanks!

Seems like its in the arm buildfarm so you could just use apt-get to install it
http://packages.namniart.com/repos/status/indigo.html

jbrown,
I am facing the exact same problem as you. I am using kinetic right now and
sudo apt-get install ros-kinetic-driver-base
didn’t work considering there is no package named driver_base as such.

Could you please walk me through as to how did you exactly fix your problem.