Not able to install anything because of the following error...need help

I was trying to install zeroconf when I first faced this error.
I tried installing the uvcvideo module but it seems that it should already be included,
anyway the procedure mentioned http://www.ideasonboard.org/uvc/ didn;t help either.

I have tried a couple of things like editing the status file or removing the sources list based on
some ask ubuntu questions but in vain.

ubuntu@rudrabot:~$ sudo apt-get -f install
Reading package lists… Done
Building dependency tree
Reading state information… Done
0 upgraded, 0 newly installed, 0 to remove and 58 not upgraded.
3 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up ros-indigo-librealsense (1.12.0-0trusty-20161223-214957-0800) …
modinfo: ERROR: Module uvcvideo not found.
dpkg: error processing package ros-indigo-librealsense (–configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of ros-indigo-realsense-camera:
ros-indigo-realsense-camera depends on ros-indigo-librealsense; however:
Package ros-indigo-librealsense is not configured yet.

dpkg: error processing package ros-indigo-realsense-camera (–configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ros-indigo-turtlebot- bringup:
ros-indigo-turtlebot-bringup depends on ros-indigo-realsense-camera; however:
Package ros-indigo-realsense-camera is not configured yet.

dpkg: error processing package ros-indigo-turtlebot-bringup (–configure):
dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because the error message indicates its a followup error from a previous failure.
Errors were encountered while processing:
ros-indigo-librealsense
ros-indigo-realsense-camera
ros-indigo-turtlebot-bringup
E: Sub-process /usr/bin/dpkg returned an error code (1)

It appears that you have multiple errors. If you are trying to install an Intel RealSense camera, you will need to separately compile the uvcvideo module to include the video modes needed by the RealSense camera and librealsense. There is a set of directions on how to do that here:

Installing librealsense in ROS for the TK1 is covered here:

Hope this helps

Hi,

I followed the instructions in the first link and got the errors as follows:

INSTALL drivers/video/tegra/host/vi/nvhost-vi.ko
INSTALL fs/cifs/cifs.ko
cp: cannot stat ‘fs/cifs/cifs.ko’: No such file or directory
INSTALL fs/configfs/configfs.ko
cp: cannot stat ‘fs/configfs/configfs.ko’: No such file or directory
INSTALL net/bluetooth/bluetooth.ko
cp: cannot stat ‘net/bluetooth/bluetooth.ko’: No such file or directory
INSTALL net/bluetooth/bnep/bnep.ko
cp: cannot stat ‘net/bluetooth/bnep/bnep.ko’: No such file or directory
INSTALL net/bluetooth/hidp/hidp.ko
cp: cannot stat ‘net/bluetooth/hidp/hidp.ko’: No such file or directory
INSTALL net/bluetooth/rfcomm/rfcomm.ko
cp: cannot stat ‘net/bluetooth/rfcomm/rfcomm.ko’: No such file or directory
INSTALL net/mac80211/mac80211.ko
cp: cannot stat ‘net/mac80211/mac80211.ko’: No such file or directory
INSTALL net/rfkill/rfkill-gpio.ko
cp: cannot stat ‘net/rfkill/rfkill-gpio.ko’: No such file or directory
INSTALL net/rfkill/rfkill.ko
cp: cannot stat ‘net/rfkill/rfkill.ko’: No such file or directory
INSTALL net/wireless/cfg80211.ko
cp: cannot stat ‘net/wireless/cfg80211.ko’: No such file or directory
DEPMOD 3.10.40-gdacac96

ubuntu@rudrabot:/usr/src/installLibrealsense/UVCKernelPatches$ ./copyzImage.sh
cp: cannot stat ‘arch/arm/boot/zImage’: No such file or directory
uvcvideo

Please let me know how where I went wrong or how to proceed further.

Thanks.

What local version number did you use to build the kernel?
Which version of L4T are you using?
Where did the failure occur?

Hi,

Thanks for the quick replies.

The local version number is the same as the one mentioned in the link.
The version of L4T is L4t R21.4.

The failure occurred when I tried to install guake in the system.

Also I am currently facing another issue where post the login screen, nothing shows up via
the hdmi connection and I have only the power led on whereas I remember there is another blinking
light which doesn;t turn up anymore.

I am very new to this so please don’t mind if this is a known issue (I am searching for a solution
right now)

You are suffering from several issues. It’s not clear what steps you have taken to get to the state where you are now. The errors listed in post #3 suggest that when the kernel was being built, the buildKernel.sh step failed or did not execute as none of the modules are in their expected place.

The part of the script referenced is:

$ make modules_prepare
$ make modules
$ make modules_install

A contributing issue could be that you may have run out of room on the device during the build. The eMMC fills up pretty quick when installing a lot of packages. It’s generally recommended to build a base kernel on as clean of an installation as possible, and then add packages later.

There are several ways to go about fixing it, but the easiest is to reflash the Jetson and start from a known state.

I would recommend:

  1. Reflash the Jetson TK1 using JetPack from a host PC. This will bring you back to a known working state.
  2. The error messages listed in your original question #1 indicated that someone tried to install ROS Indigo, and Turtlebot with a RealSense camera. This is a multi-step process, and not very straightforward. If you are going to use the RealSense camera, you will need to build a kernel that supports the camera, the links I gave above cover that process. If you do not need the camera, you should not build the kernel.

If you decide to build a special purpose kernel for the RealSense or other peripheral support, you should build the new kernel and install it immediately after flashing the Jetson, and before installing other packages. After the build, reboot and make sure that you have a working system before you attempt to install other packages, which means that the monitor, keyboards and peripherals should work before you start adding more.

The error messages that you posted in post #3 appear to state that the kernel was not built correctly (the module files were missing). If you build a new kernel and it doesn’t boot correctly, that indicates something be wrong.

As an added note, make sure that you are building from a “fresh” install of a kernel, or one from a known state. You want to make sure that the kernel source and configuration matches. Some people try to build on a modified kernel (such as the Grinch kernel) and forget to grab the matching kernel source and configuration file changes. That’s why it’s important to check the local version using ‘uname’ to check to make sure which version of the OS is being used. If the configuration and the sources don’t match, we can guess that bad things happen soon there after. If you build a custom kernel, you probably will want to rename the local version so that you know it is different than stock. This also makes it easier to know if the newly created kernel has been loaded, as the “uname -r” will return the new kernel name.

  1. Start installing the other packages. Your questions have been about installing guake and zeroconf onto the system, yet the error messages indicate troubles with non-related packages, such as ROS, librealsense, and a ROS package. The troubles indicate that the ROS related packages did not install correctly (the librealsense RealSense module being the main culprit).

I’ll also note that after you get everything working the way you want with all the installs done, you may want to make a clone of the disk image to save on your host so you don’t have to recreate everything when something goes wrong.

Hope this helps

Thanks for the reply and the amazing post at https://gist.github.com/jetsonhacks/2717a41f7e60a3405b34.
I followed it to reflash the jetson to a known state. I will now be proceeding with the step 2 that you have mentioned i.e. building a kernel for the RealSense camera as it is part of the project.

As for the cloning part, I would like to know is there is a way to clone one image from a jetson and flash another jetson with that image (as I have access to another one where I was able to install everything else without any problems) without using clonezilla or dd?

Thanks for all the help that you have provided.

Note that the Github gist installs L4T 21.1, I believe the current version as of this writing is 21.5.

Jetson TK1 wiki entry on cloning:
http://elinux.org/Jetson/Cloning

JetsonHacks article (a little old, you’ll have to adjust for your situation)

If you intend to restore on a different board, delete the file :

sudo rm /etc/udev/rules.d/70-persistent-net.rules

on your board before shutting down and making the image.
Otherwise, the ethernet controller on the new board will not match the MAC address in this file, it will be accessible as eth1 instead of eth0, and NetworkManager may not like this.
This file will be automatically recreated at first boot.

Kangalow, I am having the same “Errors were encountered while processing…” error messages that the original poster was asking about. But since I am not using the RealSense camera can I safely ignore them? I get that error message whenever I try to install any ROS package, but it seems that they get installed correctly (at least the ones I have tried so far, such as the standard turtlebot packages).

Thanks in advance!