RTSP (type 4) not working whereas Multi URI (type3) is working on Tesla Platform

Please provide complete information as applicable to your setup.

• Hardware Platform : GPU
• DeepStream Version: 5.1
**• NVIDIA GPU Driver VersionDriver Version: 450.119.03 CUDA Version: 11.1 **
• Issue Type( questions, new requirements, bugs)
I have been using deepstream-app for vehicle detection (dashcamnet+type+make) for some time now using uri as input (type 3), as I experienced instability with the ip cameras, I looked for a way to keep the process going when receiving EOS so I saw the rtsp-reconnect-interval-sec function was working only on type 4 source so I used type 4 but the stream is not recognized as a type 4 source:
WARN: <cb_rtspsrc_select_stream:537>: (null) not supported
ERROR from src_elem0: No supported stream was found. You might need to allow more transport protocols or may otherwise be missing the right GStreamer RTSP extension plugin.
Debug info: gstrtspsrc.c(7052): gst_rtspsrc_setup_streams_start (): /GstPipeline:pipeline/GstBin:multi_src_bin/GstBin:src_sub_bin0/GstRTSPSrc:src_elem0
INFO: <reset_source_pipeline:1433>: Resetting source 0
WARN: <cb_rtspsrc_select_stream:537>: (null) not supported
ERROR from src_elem0: No supported stream was found. You might need to allow more transport protocols or may otherwise be missing the right GStreamer RTSP extension plugin.
Debug info: gstrtspsrc.c(7052): gst_rtspsrc_setup_streams_start (): /GstPipeline:pipeline/GstBin:multi_src_bin/GstBin:src_sub_bin0/GstRTSPSrc:src_elem0
PERF: 0.00 (0.00)
PERF: 0.00 (0.00)
PERF: 0.00 (0.00)

• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
This is my config:
[source0]
enable=1
#Type - 1=CameraV4L2 2=URI 3=MultiURI
type=3
num-sources=1
uri=rtsp://localhost:8554/DASH
select-rtp-protocol=tcp
rtsp-reconnect-interval-sec=10
#uri=rtsp://guerno:gram@2.138.49.220:8080/video/h264
gpu-id=0

I’m using a rtsp server (https://github.com/aler9/rtsp-simple-server) for proxies as input and the test was made using ffmpeg stream with a tcp protocol: ffmpeg -hide_banner -loglevel error -re -stream_loop -1 -i …/data/dash.ts -map 0:v -c copy -f rtsp -rtsp_transport tcp rtsp://localhost:8554/DASH

I also tried with no forced tcp protocol and it could not work either

Thank you for your time.

just figured that it was a ffmpeg issue so I tried it with gstreamer and it worked

Glad to know you fixed it, thanks for the update!