RTX A4000: Runtime D3 on Intel 14th gen Desktop

Hi I want to use D3 runtime on a desktop running a server, however it does not seem to work.
cat /proc/sys/nvidia/gpus/<pcieid>/power results in showing that D3 runtime is disabled.

I have tried to trouble shoot this however I have run out of ideas, hope you guys can help me out.

  1. I have checked if CONFIG_PM is enabled in the proxmox kernel, it is.
  2. the nvidia driver is started with the right options, NVreg_DynamicPowerManagement=0x02
  3. The right acpi methods are supported, checked by dumping the ACPI table. (I am new to this so maybe I made a mistake in checking this.)
  4. the gpu is an RTX a4000, so should be new enough on driver 550.67

I have attached the nvidia-debug log, hope to get this resolved, so my gpu no longer takes 14 watt to do nothing all day.
nvidia-bug-report.log.gz (1.7 MB)

Please remove all extra kernel parameters, especially nommconfig

1 Like

@generix
Hi Thanks for the reply.

I remove the extra command line params,
now I am left with:
cat /proc/cmdline : BOOT_IMAGE=/boot/vmlinuz-6.5.13-3-pve root=/dev/mapper/pve-root ro quiet intel_iommu=on iommu=pt consoleblank=300
This still results in Runtime D3 status: Not supported

I also tried without iommu to see if it made a difference, it did not. As such I went back to iommu enabled since I need it on for this build.

Please find attached another debug log.
nvidia-bug-report.log.gz (1.6 MB)

In the meantime I also tried the open kernel modules, this also did not enable the feature. At this point I am just really looking for a better guide on how to enable this feature on desktop. It says that the feature is experimental, so if there was more info on how to enable it I could at least give feedback on its operation. Now I can’t even get it to enable.