RTX A4500 laptop GPU causes USB transfer errors when enabled, none occur when using integrated Intel GPU

I recently got a Lenovo P16 laptop that came with an RTX A4500 GPU in addition to the integrated Intel GPU. When the A4500 is enabled, I get CRC errors over a USB connection to an audio converter. The CRC errors do not occur when the A4500 GPU is disabled and the laptop is using only the integrated Intel GPU.

So the RTX A4500 is corrupting the USB transfers.

Has anyone run into this issue and found a solution?



Hi Richard,

I am having similar issues with a brand new Dell Precision 7670 which has the same GPU. All sorts of interference is pulled over audio devices either plugged into the 3.5MM audio jack or over a USB audio converter to 3.5MM. I’ve narrowed the issue due to the NVidia GPU because when it isn’t doing some of my professional workloads the issues go away. I can recreate the issues on demand. I think something in the power delivery of the GPU must be leaky.

Did you ever resolve your issue?

Hello @mirage3020 and @richard96, welcome to the NVIDIA developer forums.

Sadly I don’t have a solution for either of you right now.

But I was thinking, could what you are seeing be related to

This is actively being worked on from NVIDIA side and might cause similar issues as you reported.

Beside that there is not much to recommend other than talking to the Laptop manufacturer, since this could be an issue related to the Laptop itself.

Hello @MarkusHoHo,

The DPC latency issue you reference has a similar kind of effect (corrupted audio) but for a different reason.

DPC latency issues prevent the audio buffer from being filled in time to meet the transfer to the audio device. The issue I’m describing fills the buffer in time but once the transfer occurs it is being corrupted, hence the CRC error.

The software I’m using can distinguish between the two causes. The issue I’m describing is not related to DPC latency.

Also, DPC latency issues are common and I’ve encountered them many times in decades of using computers for digital audio transfers. I’ve never seen a CRC error prior to getting this laptop.

I have certainly been in contact with the laptop manufacturer. They don’t understand the problem and have decided not to help.

@mirage3020 the issue you are describing sounds like analog interference, not an issue with digital audio transfer. And no, I did not resolve my issue.

Thanks for the clarification Richard, you are right.

I’ve never seen a CRC error prior to getting this laptop.

And neither have I. I recall checking your post a couple of months back and I asked around internally. But since I did not receive any feedback that would point to either a solution or even a separate occurrence for another developer or customer, the topic got left without resolution.

Please forgive me if this is something you tried before, but do you have Resizable BAR enabled in your Laptop BIOS? (Above 4G decoding) If you think about how data could get corrupted, it could very well be about BAR conflicts.

Or even a conflict in IRQ assignment, between LBI and MSI assigned interrupts.

I am sorry that I can’t do more than guessing here.

Hi both, pls never forget to report these system level issues to your system vendor, so Lenovo and Dell as well. (Part of) the solution must be rolled into production by the system vendors as well, so they need to be aware, and will help us with repro and debugging, to accelerate the process…
Many thanks

1 Like