RTX A5000 GPU Passthrough/Linux displaymodeselector problems

Firstly, I want to use my A5000 for GPU passthrough purposes on a Linux host. I only need one virtual machine at a time. Do I need to put the A5000 into displayless mode in order to use it for a GPU passthrough with KVM?

Secondly, I downloaded the displaymodeselctor tool. I disabled my display manager, uninstalled the nvidia drivers, blacklisted nouveau and rebooted. Then I ran the tool to list the modes of the A5000. Unfortunately, it displayed the following:

GPU ID:
Graphics Device (10DE,1EB1,103C,12A0) S:00,B:09,D:00,F:00
GPU Mode: N/A
GPU ID:
Graphics Device (10DE,2231,10DE,147E) S:00,B:0A,D:00,F:00
GPU Mode: N/A

The first GPU is my display GPU, a Quadro RTX 4000. The second GPU is my RTX A5000.

I believe the Linux displaymodeselctor said it was version 1.48. I have no Idea what version the windows exe proclaims. I will note that the modified dates of the tools(displaymodeselctor and displaymodeselctor.exe) differ by more than a month and the A5000 is pretty new. Does the Linux version of displaymodeselctor know nothing of the A5000 or am I missing something?

Of course, none of that matters to me, if I can do a GPU passthrough without changing the A5000 to displayless mode.

On a slightly different topic, do I need a vGPU licence to do a GPU passthrough with my A5000? I think that it is unnecessary, but I have found no clear answer? I have inquired about this to the vendor who sold me the A5000, but I have yet to receive an answer. I think the salesman would gotten back to me back if he thought he could sell a licence;-)